summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pytest-mock
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.11.2.ebuild5
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 7af8963120ff..9374d2597709 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -3,7 +3,7 @@ DIST pytest-mock-1.11.2.tar.gz 22825 BLAKE2B d6843d1cb1afc0d5a242103ec4900d56418
DIST pytest-mock-1.6.0.tar.gz 17780 BLAKE2B 4fbc0cbd951668eb2ce427496c54e958591fe368bd42544eb1d0379adcb3d0e10b223ab044956e4003aac88665b3132dcb9d167442d6d85a5be79edea36881ca SHA512 c3b897be9156d57d7012e95b620c543500b849d7076224e3328d3783311210c57141dfb82c01bb98e5e419125dce0f68f6631bd610f4909f5ac1798458a7949f
DIST pytest-mock-1.6.3.tar.gz 18482 BLAKE2B 1c0d366e5afd1b247ff454716b6d96d9d68846adfff81adc0ea079a72d3e7710fd9385122723cfee69965588235ec2deb1e0b52328ace5c967652c93b404cea3 SHA512 6857f373728d3f2c6b152d4f89da3590e2e74795695dc9f4f3704a4e0250e49d705ce0de4121a801ac35c83217678a95a5023338124293ca74db406941f5072a
EBUILD pytest-mock-1.10.0.ebuild 1053 BLAKE2B 557904303bf9bd18f56a6dea0e3f9094210f11a5a8d55e9ee751d547812a89160fbded658aa8a9695742821322ec050f13e74eda728c6afa6835083cc31ed31b SHA512 105f9f1a88237c927715276d8720af98a11b52c26adabb2565ac09d9da639cad1aafe2ddc2251b1ca5ee7215d570af71d479de51be72f9a6be3037b71710da75
-EBUILD pytest-mock-1.11.2.ebuild 1310 BLAKE2B bcac1ef3be8f944a61d18e222a4f39e402104159a2d92e90667f2f744fd32ef44c8615b941e56979b1def3ae80df58e570784ba877683903c600e82312e05a41 SHA512 6e6b28103c8283408261ed1b252fe4cfdae5951bd0909fed65ade3e0f76104f34eb33567bd9a1d42763c7689928ab40393d8c2180fb33b93c74f15c602049f09
+EBUILD pytest-mock-1.11.2.ebuild 1461 BLAKE2B 6aa7dfef611ecea71251c2c8c0d7be218d12ff3fd1cb0e61d8f98060cf484d5fcd2939ac039bdbab44b62c269a7fed99ce565a0a540d4a4e277ff365c138f602 SHA512 7ffa49348dfd8af1384de09a13ad36da80338973b10aca0685eff7750914d25fc4b7b7aae3b85dde9292fddec5f3905e075ade3538ccb373c22c2ea423b37f73
EBUILD pytest-mock-1.6.0.ebuild 1082 BLAKE2B 3bbb3cde15139fa3c9134250de2419623161f53a69689b64dfab6f81f73c4c1afa6001c0f8ba119376ebae6881f16c4f9a117609e0d6794aaf30cb4efc4be553 SHA512 c71cfc5c6c35799529fa21e9f0341dc5178bea61a7f6975a779c677dec3dad3e94540236839c5547a5ca179cb0cb16121cc3d0c17f7409c1812ef0312fe3c551
EBUILD pytest-mock-1.6.3.ebuild 1053 BLAKE2B 4525429f621c5d06d9ec07ecfb14b429ac52fa7861168024d0d832449aa184ef04a5c331157cf10befe30c5902299741b2019326d2f197d080a6313388a42901 SHA512 ba49f51d47920280f96a9697c0ec81f14133019fa50b0bb43985a69908d56d6fc6ed7f1c12ff8e4c898de666f1a673216da802834f48420b0af14d77d9631a42
MISC metadata.xml 433 BLAKE2B 78d844dea9620760c0766eda59e09f93248fba58778f26fb4dd53e864ece455ede7299db90bec0fe11fdf64b762e2c660c260ce10e3758bb8e25024b1bf2877f SHA512 16324c7a2ce4e3e7261b9be389d646ba8e797719b6dd6782fd66311aefa262e338bac99c09a9399d55b362b941cecfc8039fa14e53b79e214359ba6d294c9529
diff --git a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
index 9abdcee85b10..533ff838f0dd 100644
--- a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
inherit distutils-r1
@@ -12,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,6 +30,8 @@ src_prepare() {
sed -e 's|^\( def \)\(test_failure_message_with_no_name(\)|\1_\2|' \
-e 's|^\( def \)\(test_failure_message_with_name(\)|\1_\2|' \
-e 's|^\(def \)\(test_detailed_introspection(\)|\1_\2|' \
+ -e 's|^\(def \)\(test_assert_called_args_with_introspection(\)|\1_\2|' \
+ -e 's|^\(def \)\(test_assert_called_kwargs_with_introspection(\)|\1_\2|' \
-i tests/test_pytest_mock.py || die
distutils-r1_src_prepare
}