summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mpl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
commitad75ca50360f9590325f0f709c091832b70eab1d (patch)
tree8a0b109f05da2a3728e461abf6e31347c2e8b0b2 /dev-python/pytest-mpl
parent7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (diff)
gentoo auto-resync : 08:10:2022 - 01:28:43
Diffstat (limited to 'dev-python/pytest-mpl')
-rw-r--r--dev-python/pytest-mpl/Manifest3
-rw-r--r--dev-python/pytest-mpl/metadata.xml13
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild44
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/Manifest b/dev-python/pytest-mpl/Manifest
new file mode 100644
index 000000000000..782942fd33ca
--- /dev/null
+++ b/dev-python/pytest-mpl/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-mpl-0.16.1.tar.gz 663585 BLAKE2B aad171260a10417aab15e7e55115c2fe02aa33dcf8336634281e1a1dad4d1c5ff08293fd9a67be025ec6cbb18c42bc9eb7ccb86275c0fcc7f4bf33a035fc0927 SHA512 64c1689f1698f9223082bc5c6817a1d4f9b413cb193894c23b1e0302254a6358cb3e354ac92ec47677acf460a41d05b2b527c834fd0fbbde04c070b0af8f46e1
+EBUILD pytest-mpl-0.16.1.ebuild 1080 BLAKE2B a1dfcc77eff6d5cc944cbd0597815a91a1db4c44dd73bc0328ea82b7df5cad93fdb6d2485255a416510ed895192818825415539e583781322b8a277740c50d20 SHA512 96264f222e57741e45ea99f2da31d1061967cf7fca0757116794e3b3247c7cdc76310ed37b700c5f94403c4c7e08b818811bcfa266f8a56dfa1816b3a9667090
+MISC metadata.xml 399 BLAKE2B b2dd8993ce1e55737997ac3e6c0d26edecad7721c319073b8bc12117b1387dd3b6a1049837b5f97d97f5539d1253bf888f00caca6f0bbb46a73292ee6bd08f0f SHA512 5e3c8b4c47771acf6fe345f3e1d1ae59e66a2bd028ff57969cd3a93aef971b7103a7b0d847f1e53af54075603f9868d5c09895f4ea3a1d93009b07449496d317
diff --git a/dev-python/pytest-mpl/metadata.xml b/dev-python/pytest-mpl/metadata.xml
new file mode 100644
index 000000000000..c9b79fa5f81b
--- /dev/null
+++ b/dev-python/pytest-mpl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-mpl</remote-id>
+ <remote-id type="github">matplotlib/pytest-mpl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild
new file mode 100644
index 000000000000..9db1c3e57234
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Facilitate image comparison for Matplotlib figures"
+HOMEPAGE="
+ https://pypi.org/project/pytest-mpl/
+ https://github.com/matplotlib/pytest-mpl
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ tests/subtests/test_subtest.py::test_default
+ tests/subtests/test_subtest.py::test_html_images_only
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ #local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ #local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}