summaryrefslogtreecommitdiff
path: root/dev-python/pytest-param-files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-param-files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-param-files')
-rw-r--r--dev-python/pytest-param-files/Manifest2
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild13
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
index 54e742bfe19f..db2323a2f86e 100644
--- a/dev-python/pytest-param-files/Manifest
+++ b/dev-python/pytest-param-files/Manifest
@@ -1,3 +1,3 @@
DIST pytest-param-files-0.3.4.gh.tar.gz 6882 BLAKE2B e2e96bd2cf7b8676f92eeb7821ef76f1f82bb066210170ed4d04a16a7fb3ce346bcd63688ef9d46118c03fd74812fd821fff0414565befb8c558d03d15af2945 SHA512 2df6fe798aab743fdbf892b88ee1d09c554119429167e85bccb87e4ae9d487f8ab5a66c4157827500e8a5d2930277c7490348f6c38f23243e421d5449bde2df5
-EBUILD pytest-param-files-0.3.4.ebuild 642 BLAKE2B a4657729cedfe84412be512e84e70dd0b59174111fa08dc972ede712ad201eb3875ff03f3e81a3ad5ce87cd18a1fe4d529c373b4c942205cedd754ab9802683b SHA512 ac9f6d852663f2a9542e2c3f48d4ffb45fd8191861180bf4297eaed3ac08c2d2518fe0e6e8134fbcaf0262f425b89ed544c98d494cc97fbd9d0d79cd13884354
+EBUILD pytest-param-files-0.3.4.ebuild 656 BLAKE2B 7edf2380892e4cd9248b56ed240b6d01fec3d00c516ab0b5cc3a3df24fdcb535281fb3bdc9a0e273707abb4f0fc9c774ee2abd159e4f3c747aafcba2684b5a33 SHA512 07758a726d321205427f1eaf8d281f89f95079e46caad6f74e2508e1c3e3c213171537a4febbb929c6580f1870621566eaeef12929439f29d8af60f144b17f9b
MISC metadata.xml 417 BLAKE2B 94bde89ae7cf0181aba1215f8a406889a4473736c37cc325c57635f590f72369402e54f8e54f0b528c9757229b4fdf8608b292a15cc6fa83a997aeb53a64b4ea SHA512 f5b341a0619f750edc6e3f22fc3cfb0c5204d2ce19a756df0f5b282f97fe133f8891105c48b532711bba826ef4cca935eeed4fbb0703da5213cbc3074b7229c2
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
index 5e0850cfa5ad..816bb8658910 100644
--- a/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
@@ -3,13 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Pytest parametrize decorators from external files."
-HOMEPAGE="https://pypi.org/project/pytest_param_files/
- https://github.com/chrisjsewell/pytest-param-files"
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
SRC_URI="
https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -19,6 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest