summaryrefslogtreecommitdiff
path: root/dev-python/pytest-param-files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
commitd5c5aa9b48bd6a821f5e0a1a98474ac35fb21360 (patch)
tree9de3699cbe327fb5dd93a6ec37b895f9fdb94494 /dev-python/pytest-param-files
parentc6a12f3c8604a9269cfb82d666fc716df0e67792 (diff)
gentoo auto-resync : 29:07:2023 - 04:38:40
Diffstat (limited to 'dev-python/pytest-param-files')
-rw-r--r--dev-python/pytest-param-files/Manifest2
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
index 2333679e41ba..9463a05c133e 100644
--- a/dev-python/pytest-param-files/Manifest
+++ b/dev-python/pytest-param-files/Manifest
@@ -1,3 +1,5 @@
DIST pytest-param-files-0.3.5.gh.tar.gz 7245 BLAKE2B 2a67c5ee30d6efb6b7ca7e3272c19c05dda460167cb1709693560ffe06b0ae39ae1b93fc5d6375f4e9cda21e3e02051424789afee55d201cfe070be8a05642ec SHA512 e80eddba2934fe5a6b68645cae243afa936ea3362a29d0b8a8ae4e11229ffb877f1ace9f41ac96d182d5787740fa76af8b106069feb95a7cab1ecc6f8d1088f9
+DIST pytest-param-files-0.5.0.gh.tar.gz 8563 BLAKE2B fa3907f3da7607caa3ab4933052ce70bc87bdf1b55983ef9660dbf0d6ae8a838d185be7f03f8ee5a1beb5771bb9f19f46fc012eea1eb7ca6331ba3c9626c72ca SHA512 cfff7ef20d453cf50a72e78d546a948d49c415c212ffba8e0ac4abe1da2decd9097930777b5aa182fb97c9c5c01e4b00bee25bd27f34c6f35a14ba7177d17a16
EBUILD pytest-param-files-0.3.5.ebuild 681 BLAKE2B b6cd24aee6f107261b03304dc8395ce83dadc4a0dc5a0ce7819f99e616db05ad1e9cbe858a0724e80ec2aa3e1d0b641652557f0d7a1afc4ac889149970a6b52c SHA512 2851e45eb8a57649b5af953f9f5a054e687daeb491b82407f32de3f55cb3b20fed90061614bc6684d6ab756d653c7110beab28a23441c8dc42e0694b7f3e9f2c
+EBUILD pytest-param-files-0.5.0.ebuild 726 BLAKE2B 9c9cb4a4006440c5a07eeebbfd8d2f89f8a6eff94e2b394c6e96f4baafe460369f1439824efd60a5a9b30426cef916b0864358ccf2c8558d50f8f2cfbb86f491 SHA512 62b17f4d9653460034f4488f6af14e6163d437035a9a10ed993472c6511ff689ce6772538db474f4cd172244e8062c7ee3f240f46a265229bd103af79af432f1
MISC metadata.xml 417 BLAKE2B 94bde89ae7cf0181aba1215f8a406889a4473736c37cc325c57635f590f72369402e54f8e54f0b528c9757229b4fdf8608b292a15cc6fa83a997aeb53a64b4ea SHA512 f5b341a0619f750edc6e3f22fc3cfb0c5204d2ce19a756df0f5b282f97fe133f8891105c48b532711bba826ef4cca935eeed4fbb0703da5213cbc3074b7229c2
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
new file mode 100644
index 000000000000..5982d88730fe
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest