summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-pep8
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-pep8')
-rw-r--r--dev-python/pytest-pep8/Manifest4
-rw-r--r--dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch9
-rw-r--r--dev-python/pytest-pep8/metadata.xml11
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild33
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-pep8/Manifest b/dev-python/pytest-pep8/Manifest
new file mode 100644
index 000000000000..834b4c9007f8
--- /dev/null
+++ b/dev-python/pytest-pep8/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.6-MANIFEST.patch 178 BLAKE2B 498bebd63c6be42e3a73063709dc2f315a2c8ec2234d43436ff3f076f768acf566d81a21ed76412fcf9da929290d355cef02200d91938a9c76df08a296d1baa4 SHA512 f63f80ea3ed7bf9241a029e4cfaae2e41ff9553effee7a85cd492cb3b57d9b54a17e684896be443ba5df08be1d07625c4e6769d9cab9dff952f10eedb92ca1cb
+DIST pytest-pep8-1.0.6.tar.gz 7271 BLAKE2B edfe2ac899586be9f7fd88f8bad5e5a18200da128d291735a30e374316b5ad449a08956b839605bf3f83b91931fb6890557445fd94f3a5136c7a44ee5e7f91f3 SHA512 162d9e25c264ecd82a51c6798ae75493c724a847ad8cdd953225f73e587f9a14298a6281e541695f6e7471a6121e9b0e4f694270f45ead851e392efcd7aeb758
+EBUILD pytest-pep8-1.0.6.ebuild 715 BLAKE2B 7b592f3d64e78716cf5af91a20671b88b52e60290e855ef927df7c664fd8c4431399e1459ae68d6302e97dd9079bc7b033697f48c95def816d673ddf633fb00b SHA512 e607a394d6022d41abd0b4e2f04cc7f6a2d5568756430b726e061058e82dbe275e448bd633994c5ee6dce78dc762b9a5e45cae74f2df8a00e0a5f2e5578b5652
+MISC metadata.xml 324 BLAKE2B 3e0d5894a9d05fcf94a05abcdaba2da483d9b6db134df730bd436b85295a60504b2b30004eaf63396c31783d62ea042db28e0a28e24ff27255c40c4e4704b09d SHA512 3622d9663e7966ff8a566971b51f886be021d2e58254836d3c5dfa62e5001289d8d9beabb3f980af243a91cbfd527a076db628a1b29fb6562041a88cbc617b59
diff --git a/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch b/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch
new file mode 100644
index 000000000000..3e9d2f20dcda
--- /dev/null
+++ b/dev-python/pytest-pep8/files/1.0.6-MANIFEST.patch
@@ -0,0 +1,9 @@
+diff --git a/MANIFEST.in b/MANIFEST.in
+--- a/MANIFEST.in
++++ b/MANIFEST.in
+@@ -4,5 +4,3 @@
+ include tox.ini
+ include LICENSE
+ include test_pep8.py
+-graft doc
+-graft test_pep8.py
diff --git a/dev-python/pytest-pep8/metadata.xml b/dev-python/pytest-pep8/metadata.xml
new file mode 100644
index 000000000000..d127354cc52b
--- /dev/null
+++ b/dev-python/pytest-pep8/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-pep8</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
new file mode 100644
index 000000000000..c8561edd55ac
--- /dev/null
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check PEP8 requirements"
+HOMEPAGE="https://pypi.org/project/pytest-pep8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/1.0.6-MANIFEST.patch
+)
+
+python_test() {
+ ${EPYTHON} test_pep8.py || die
+}