summaryrefslogtreecommitdiff
path: root/dev-python/pytest-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-plus
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest2
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild (renamed from dev-python/pytest-plus/pytest-plus-0.2.ebuild)17
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index f4e68ab672e5..37608626e313 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1,3 +1,3 @@
DIST pytest-plus-0.2.tar.gz 8210 BLAKE2B b8a28e72cfb4e10daa021528de9b5df2e9eb0bc4e911557c7c14a0825284787e94992132c0b74881867a41b55a67785c60b9b87a1594ad33fb57ebac8de391a6 SHA512 e16a03433cb6eb30b6881bec99482bc65cb7d1fa3d0db855befe666c0645d4b5ec02debde9dec4322ed0a0b77d3ac3f1cabda0cf98f375ffd68dc29fb55f5139
-EBUILD pytest-plus-0.2.ebuild 622 BLAKE2B ce7062baf929233ad5c8e1c89efe7fa85ace4740b4fbb5e55a8a0eee397b0970e18e613ad1ccd8160e149ebf025779ac5baa6e3aa332fdc254eacee485c6326d SHA512 0ca7038df407ce27686687b054d4404639870ee278a5efa355ce7cd56f7f85dbea5b4f00cca5c5d63db717f9d31809b396d9887f5e465a4e481fa03a08407127
+EBUILD pytest-plus-0.2-r1.ebuild 660 BLAKE2B 5173858f8d85857d44519d05f56daa147456df76b540a831883111366a2c827445240453823529c4e7eaa6ca50d4206bd5857d2422413b257e1b7536f865f626 SHA512 b04dafe2c78aee3d91d051d24ee6a29debaed70b48b91247279e10a400c926112691b2abbe274f33a6b6d0a0dd9deae84a1b134e1ed330f154e7d317b1834102
MISC metadata.xml 406 BLAKE2B ae1b1a2c28f45b4dd7f752125161396de88cf2ed3881f37f72dc7938cd2ea6485c995d0409c6fbaebeb7b1d4cf59736496549702d7a9d825a2ee5eb1e6a65fdf SHA512 33668115e05810055fa79f5d74c5d3b6eca5bb53e0108a257cb57bb496ebd0292c1dd3f5b33feee58c20c2c381a926c870f9576355171a91106c21fea41d6ab3
diff --git a/dev-python/pytest-plus/pytest-plus-0.2.ebuild b/dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild
index 0e691d690afb..a618aaa1583a 100644
--- a/dev-python/pytest-plus/pytest-plus-0.2.ebuild
+++ b/dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -15,9 +16,13 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest