summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pytest-pylint
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest4
-rw-r--r--dev-python/pytest-pylint/metadata.xml2
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.18.0.ebuild32
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 0d13a6852bda..607a89813323 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1,3 +1,5 @@
DIST pytest-pylint-0.17.0.tar.gz 11660 BLAKE2B b536dcaaf0ac652dcbe66018fa22e120782496de58f74003c523eb003ff0556f9b738e528a85724a1e589e18bb0024d99fbeb581b7f5b36ec349ad07da8d26d0 SHA512 a23937ec191ef14829530ac6bf31b882bc250f312e2ba6e3b8cc1187c888511e4b67ffaf5bce176556a621fbf80239b30c43c635898d458bb8d819e92a9f8142
+DIST pytest-pylint-0.18.0.tar.gz 12448 BLAKE2B 9d0cecb08fc87d7e2aade47af3f2677431776a425726c281e9abc5fdeebb84f38ab4a97e405ed407b1cd241eb97a8cd90e878af61f818b46cab5f9fba5ca3d5f SHA512 a0716104d288774d4c3ab596f30a33cf439df5031647912574c31eefc3a84e69e82fc362f77e73b437c7566a596d2ff8bf51a332626a7fa7468cea3b916e9ad9
EBUILD pytest-pylint-0.17.0.ebuild 1118 BLAKE2B 2afc692f96d558d956eee04d70b2a516babfff606a858117efeb3f5efd0631823f3a99706dd10441d682101ff994f732f8dee84a2367390245f28cc85bd25086 SHA512 9047a6777d0ea48b040b4249531b2e5254dd535202a3bba2745614286f4d2d628e9a99aaf950515374cb2d4dfee17595a3b61c0da109e63479b4fb580fbb5626
-MISC metadata.xml 428 BLAKE2B 5986f5476c70157e31680be898d8b45cf38d1fa303aeac5d9336796e0b5941de9170d781ecddf308174b9b4aff51ec9fefa5c6620ee49f9121005aa86229a740 SHA512 65370aeb2b8c39941a34035ae9c44f5e19fdf4c533e50f9641870b2496773a5f782460f4518f79a2e45489c871f3e18d05a2d36fe8610fd1ea87e616f39a9a19
+EBUILD pytest-pylint-0.18.0.ebuild 827 BLAKE2B 5a3cf1127d9c4cee9f363d8bd6de620d874ba31ae2e0294f7a76f6951d78ae3f9b607f68686bc087dc78af438c5f5da17d9cfd3cf1eacfff89c2be76ce836321 SHA512 b3a35d0585bee70baff8fa77ab3e14c06c9c9e78d3d8a1c9ac08ebe3925617ea2ad1c9f4c559de5a8f495ded9fefae5be087b0bb4ece907d76326bf674a0a4ff
+MISC metadata.xml 474 BLAKE2B 4d013c02cc0b5fc2353986b665fd919f8a678d7f4e39e628b6fce39cfca8139a619dc4e27c5de67f2271f9e00a802e1422e8d61f5f4d758a3cab0c1b00692819 SHA512 434efa91bad6e55caa520e409598c6504a11c116f4ffdddf77f7fedd9bd9135e2f90e2fb4f1bd551c492c0af13134a12b75f6f29172326e4218471f1466c3f81
diff --git a/dev-python/pytest-pylint/metadata.xml b/dev-python/pytest-pylint/metadata.xml
index 4f79f21e49ec..cb65d5c32b97 100644
--- a/dev-python/pytest-pylint/metadata.xml
+++ b/dev-python/pytest-pylint/metadata.xml
@@ -3,7 +3,9 @@
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
+ <name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">carsongee/pytest-pylint</remote-id>
<remote-id type="pypi">pytest-pylint</remote-id>
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.18.0.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.18.0.ebuild
new file mode 100644
index 000000000000..447f4c2ddd2e
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.18.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pylint-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # Disable flake8 and pep8 options
+ sed -i -e '/^addopts =/d' tox.ini || die
+ # Remove pytest-runner requirement
+ sed -i -e "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}