summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-python/pytest-qt
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest3
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild41
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0.ebuild2
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index bd8abb3823f7..cc70d6ce3143 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,3 +1,4 @@
DIST pytest-qt-2.3.0.tar.gz 106707 BLAKE2B cf02aed42481cbcadfaaa15c883f3055337f6f32e33b7dfbce986ecd9936218ee5bfe9f21e1a910aa970e7adf88dd24415d63f40655e8417863e96a4285fd466 SHA512 2bda4b5f60ba68b151ce62972661cd704e40f4cadaef2583882099e96100b5c5b9398de796e851579e026e9736e07539c4db8c10eef16929ce729c4dd7a22940
-EBUILD pytest-qt-2.3.0.ebuild 899 BLAKE2B 4eee95fb161bdccba4d69121a600e8377c8c7ea4f32e1f4cddd70cbe7d862291c21c1e9b61b7b31d6953fcd7d68c188b9c6fd021a68b7b55e20aa4b3d248c2ac SHA512 908cbec8a3c9ae8ca9e7408d2484f6c23b6d9fc7aa3fc679ccfbbe0e909cb649215d730a66c9678ab822cd80ac8eb6f158185009956147ada7c5eaff631494be
+EBUILD pytest-qt-2.3.0-r1.ebuild 876 BLAKE2B 2f0a1c2fc54bd71a8601168f2aaeb75d138b15f5b1fe0ab730e3d1e241d62afb57b36e4e441f9f8ac98e07946213f6637accffc848a03f51f0c62d33733e3233 SHA512 570152e67299a36213593bd213fa9370a147ea641af8e1a30439ea00e0180b1707610b6ffcda185b7e8ad0698c4b0ab2bb388f38b8de9cd5285d4583acca2804
+EBUILD pytest-qt-2.3.0.ebuild 898 BLAKE2B 252414587ec176bfe22b329754eb953ede7b841943b9a5285a2092665fa5e8641e2f0649df02ef364b84211f576d6963ad0897868161a6153f596fe4bc5da7a7 SHA512 20fe62ec12efe92b57aba24cd80925da2657ebe65c1cdf3722602b5dcb3f415b3a9f88362f581270b4630c1a12d3fa19ef6478d5314c6238a3a9bd305cc423bc
MISC metadata.xml 396 BLAKE2B f4d5cdd1823e62b7b0443623b9f34ffbd2f5f7944ddca44dacbeba2b4a3daa438203483b96f113ab821d4e5dccdc6e9cde8faa3a6a4a53d190b567af07cb9b61 SHA512 c5c3149a783a4d72eb7f0582d416b0f6c408d86878892a0ccde2aa5ec672a55c0c2658af31cffdd8f66500420fa3ee43dbda98397a1efb3cc06697e9e1af84ac
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..cbbfd24fc3d7
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
index 6c47cfd380b1..9032b7bee755 100644
--- a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc"
RDEPEND="