summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
commit31a02d889028bf30f7b376b935aa05c2140d3c66 (patch)
tree6b211d58d5072baba31037fda71f6f421c38e5c8 /dev-python/pytest-qt
parent8f53b8011f9c960a02775a71c3805e13e72237fd (diff)
gentoo auto-resync : 08:02:2024 - 09:59:13
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest2
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.4.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index f6e6c5498d73..8c9f06f0d0f8 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,3 +1,5 @@
DIST pytest-qt-4.3.1.tar.gz 125223 BLAKE2B b7ea852b4f0a97950ff4b8f03983639a30dcd8b3532a52f0d78a5074d1220817a0853a040eba71798fd74fba27cd77eeafff2cf12b177693d77f9bd954d841a4 SHA512 e77bd0817f9dfb492ddcd9cb605b07d1e468ce7b52dce7519f2f96afd004f7796a028998572c589444e9737278a84efb887c801fb3bcc79a71c48ab849070114
+DIST pytest-qt-4.4.0.tar.gz 125443 BLAKE2B db2653ffd220e6507edd9cd2610904e5d9c1f5b39edf7b2d5043ecb7951361a6bf75618c9847b62432e0182433f2df528fce300888cca405bdc03502d6ebe717 SHA512 57c6a1866c7685db5301faa42298f11ef3d3a030cbc72fb109a8d6166621625fac89365671f781e5c3d652a190567bec3bae6f12cdab20812f43c7ef8e4518fa
EBUILD pytest-qt-4.3.1.ebuild 2094 BLAKE2B 597ba8677b1707c198903dcc019f71c9e027a19f627182d3fcf3755ec6be6545c0803c07fb66de592d1b17ff6159a00d43221058961042f726bf4de2235d4e43 SHA512 f66368fa1a34b41d29876c51fd9df2870029b5842d08da254dc745764d8b59b417c8a402228682ede8430c7cee5fc32d0b9ad2b585021b0fc414cda6a3ce6707
+EBUILD pytest-qt-4.4.0.ebuild 2140 BLAKE2B d89cfbf1799c6068c35e7fbd952130265d7f0283f5cf56e7ca6481ad918b936dcb2814095641f66304d6f6075c2e2460cb35bbf67974c5c4856a33f0715f8f6c SHA512 bd45b5de61a71945c222bd71ee1255ac731298e14382ee3ed99621334a8e4e522b65658874da7a9935a5315d5168093b733e580f8b7ae55293ae5eeaedb8c302
MISC metadata.xml 516 BLAKE2B be5241e39f672681b27a003d02eca0e047644cad7da57de6b3393f58760c094c1661b9d168e44bea4efd56b38225d49abd5be6e71031a0d854b878716286d3ed SHA512 77981d63d3214fd2c052f8a7eac1a439899318973807299237a9105730893ce01d4423b060f532bd4f4496418683fc5128508c7d8747ba6ee6ed0eae67e5569f
diff --git a/dev-python/pytest-qt/pytest-qt-4.4.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.4.0.ebuild
new file mode 100644
index 000000000000..66e09e0d7f4f
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-4.4.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYSIDE2_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
+HOMEPAGE="
+ https://pypi.org/project/pytest-qt/
+ https://github.com/pytest-dev/pytest-qt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ || (
+ dev-python/PyQt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ dev-python/pyside6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE2_COMPAT[@]}")
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # warnings from other plugins cause the test output matchers to fail
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestqt.plugin
+
+ local EPYTEST_DESELECT=(
+ # requires the window to be activated; that doesn't seem
+ # to be possible inside Xvfb
+ "tests/test_basics.py::test_wait_window[waitActive-True]"
+
+ # TODO
+ tests/test_exceptions.py::test_exceptions_dont_leak
+
+ # we are forcing a specific module via envvar, effectively
+ # overriding the config
+ tests/test_basics.py::test_qt_api_ini_config
+ tests/test_basics.py::test_qt_api_ini_config_with_envvar
+ )
+
+ local -x PYTEST_QT_API
+ for PYTEST_QT_API in PyQt{5,6} pyside{2,6}; do
+ if has_version "dev-python/${PYTEST_QT_API}[gui,testlib,widgets,${PYTHON_USEDEP}]"
+ then
+ einfo "Testing with ${EPYTHON} and ${PYTEST_QT_API}"
+ # force-disable xfail_strict as upstream as xfail assumptions
+ # don't seem to hold on arm64
+ nonfatal epytest -oxfail_strict=false ||
+ die -n "Tests failed with ${EPYTHON} and ${PYTEST_QT_API}" ||
+ return 1
+ fi
+ done
+}