summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pytest-rerunfailures
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest2
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild14
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 8c8b86939fd8..d9e826c4faf0 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,3 @@
DIST pytest-rerunfailures-10.2.tar.gz 15863 BLAKE2B 9f317f3a39ac234e145a14d532d2727bb9fb5fead65c05372cf95268e0f589f9de994cd3c47e75dcb354c996595698c43fccdea5134d2e1921429c8ea7b71451 SHA512 8830610276e2cc172ee372ae4d8376bc6329138751ea2737a4def6af32d05c112c872a7a180ff554018058c05ed0d109927dbac61f748586257e40b0243f03c8
-EBUILD pytest-rerunfailures-10.2.ebuild 630 BLAKE2B 6816154eccfd97c9011695649b03be5730e053b3996d428c768b0e52361bd1344b7cc6a1a0837b31114bc061c10d205fe5dbb1ad52eab80d6337290299eef9f1 SHA512 77f405afad6e2cd52703720a6d1d0c905a475dcb04cb2b3fd45ceb6026aa502036ebcd779c0cc9cb483c566db4c7af8545fd3ce35b0df41448b4dd8fc1a98430
+EBUILD pytest-rerunfailures-10.2.ebuild 838 BLAKE2B 08334775c8f53286eae0a253cbf11850b83c994887340d07751727c0e2aae08e95e978a96c34252b7b0a8780464e8e360104f731a320e5de3c0e6777e9334a40 SHA512 b022b7a9014d6981fced09cfdb4d8a6d8b3473f0475a901427a90cc391391b10952426eb303880c54fe46602473715d5dac5c879274b918a629d8ab29bb454aa
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
index 08446f32f44d..9bb95d7201ad 100644
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,11 +13,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MPL-2.0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
BDEPEND="
>=dev-python/pytest-5.0[${PYTHON_USEDEP}]
- test? ( !!dev-python/flaky )
"
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=,xdist.plugin
+ fi
+ epytest
+}