summaryrefslogtreecommitdiff
path: root/dev-python/pytest-runner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pytest-runner
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pytest-runner')
-rw-r--r--dev-python/pytest-runner/Manifest3
-rw-r--r--dev-python/pytest-runner/metadata.xml16
-rw-r--r--dev-python/pytest-runner/pytest-runner-5.2.ebuild36
3 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
deleted file mode 100644
index 399bbb83690b..000000000000
--- a/dev-python/pytest-runner/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pytest-runner-5.2.tar.gz 15534 BLAKE2B 0bcbd5991808aaa4b85b9071ce142e03287683e919687fa76f5b7929ad07dca6ae6edaf7ad30a1bc1ba0163f43505ec18ab2cd5e0462399b8252c8ca761d7b29 SHA512 5fc62a4e681cfa0ef25dc815ccbbfe1a7ca0e9e7783c2ba2db0da7d2539f11c08d6c3fad2ab3dfe7f0d50fe7bfb41127b11ec9af67ef8e32361655bc910c8245
-EBUILD pytest-runner-5.2.ebuild 931 BLAKE2B b8a00b2b0da9bfe8d78cc64361a65cfc11439226d07c56c49997c81af484e07d8d30a504608b41c3354ab6c8a677c9bced3526f5a3111d34e098a0f3b9562727 SHA512 8fcc53c31ee3a0f628459910ea73fe695d13e43bee1be35427cce59af8e0b2554cfcf114832d1a9abbc00f174620d0c78f0ef922b5d72f49237275e8f3508091
-MISC metadata.xml 495 BLAKE2B d12fa48de29a693c9e38d08e154a883d65cf1b6f75841776ce97a9e774c077bbca25283b6d1f5a2d1525e8c0d86097f00bf96a8cf2715cb348904a6efac24b6f SHA512 8293b013e89ae920695d8480961ce6c6820ffcda5c87e34fad8881bc327e68fce0cb0d2216a138bf881a9a12677e4bbd9d6acc5bb45c33507b5d6022f0f0feb7
diff --git a/dev-python/pytest-runner/metadata.xml b/dev-python/pytest-runner/metadata.xml
deleted file mode 100644
index 014232c4d121..000000000000
--- a/dev-python/pytest-runner/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pytest-runner</remote-id>
- <remote-id type="github">pytest-dev/pytest-runner</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-runner/pytest-runner-5.2.ebuild b/dev-python/pytest-runner/pytest-runner-5.2.ebuild
deleted file mode 100644
index 4f67ca4f305f..000000000000
--- a/dev-python/pytest-runner/pytest-runner-5.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( pypy3 python2_7 python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- >=dev-python/setuptools-40.6.3[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? (
- dev-python/jaraco-packaging[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-distutils_enable_sphinx docs
-
-# Tests require network access to download packages
-RESTRICT="test"
-
-python_test() {
- esetup.py pytest
-}