summaryrefslogtreecommitdiff
path: root/dev-python/pytest-salt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pytest-salt
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pytest-salt')
-rw-r--r--dev-python/pytest-salt/Manifest2
-rw-r--r--dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-salt/Manifest b/dev-python/pytest-salt/Manifest
index a8e3ed1bf2ff..2cac46909392 100644
--- a/dev-python/pytest-salt/Manifest
+++ b/dev-python/pytest-salt/Manifest
@@ -1,3 +1,5 @@
DIST pytest-salt-2019.2.1.post1.tar.gz 63824 BLAKE2B 684e1dee6df8f7459bfa1747ea017973d72bc69b87d22c65509ecada47469a94ce410034004a5df1396d5ed05557ddec90e34cb18792235babb5e0cf6d72d776 SHA512 7b9939c3bd1cbcb6d6d0b086c39e02deadd8b3c6fcc359924af7fa5afc2e443b927269b82aa5575413e4e6bbc052f4035fb17ab68dac59ea309320c0a647d36d
+DIST pytest-salt-2020.1.27.tar.gz 64141 BLAKE2B 2b9261af2de28f8dce1abcd71b586594075916c8a5dbb27a24f15b9d95a575624be118d1c742f02020d3b968ffa4654cf6cd0dabefffe6876b87a4d1d58c3d60 SHA512 b0632e21f1ea5c3b57eb681cd8b270721cafd270321b708fca65427fc89817ed9e9a4216a520f35988c6866b1ed76ed84838009da9052a11cf8782d4dcf118ba
EBUILD pytest-salt-2019.2.1_p1.ebuild 578 BLAKE2B a1535a842ab15429175c931ed36342041b9061cd42730df43639928b0b0122fe209ed2b34b397f5f11e8b98f15233cf51ea6d13dd959b20fa839e25a3ff62af9 SHA512 a984989a933648f8183257b0d69438171691beeacef2158e8b876ad76ae3239308dd1061e5a4143e09714825e36eedc883dca3e179fde5599baa586af1749026
+EBUILD pytest-salt-2020.1.27.ebuild 925 BLAKE2B 4cab63b84ac898aa0b5a1fff0de7378c07c23f8601ff651b468960175b30eb7da421952f16bc1a661b861715c0c4b878489ddf156af80216afdcea78d9b46565 SHA512 e5c8a5a53db2cf0945d1e8fbfe1216dbe0c91c73c95f12c5bec67ad5dccc87c23768f61c90fd1f4084e00ff448d80af56b0dd7574877b2ee5b3f5c173b681c84
MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
new file mode 100644
index 000000000000..fdbdf93cc22f
--- /dev/null
+++ b/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+DESCRIPTION="PyTest Salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+"
+#BDEPEND="
+# test? ( app-admin/salt[${PYTHON_USEDEP}] )
+#"
+
+# tests need network access
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}