summaryrefslogtreecommitdiff
path: root/dev-python/pytest-services
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/pytest-services
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/pytest-services')
-rw-r--r--dev-python/pytest-services/Manifest2
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-services/Manifest b/dev-python/pytest-services/Manifest
index 75179458a2b7..5c97c0581f97 100644
--- a/dev-python/pytest-services/Manifest
+++ b/dev-python/pytest-services/Manifest
@@ -1,5 +1,7 @@
AUX pytest-services-2.0.1-lockdir.patch 1085 BLAKE2B 09982cf4874d82a332b441e4538d1fb177735af3acb2ba2d7fed9c0a2ef006841ca0c4221fc51c0472a0a94c49bbcb72877c67b5c7630333f550e3fda1b5aa91 SHA512 7b5d4d5adb722936bd3593ed4e12fa2ca9bc3aa764565d9cbbea2d70424d9811d5838e97bbbe8fafa2f73acb8bdfa6c705e8c4aec12b5b6556b1e4c8db629ea9
AUX pytest-services-2.0.1-no-mysql.patch 821 BLAKE2B 3a041e51c0e2c08ce8727eccdbfac36eacec2542d8d8cc7ab7544f46916b47a62e960437821f8fa85fe968b9e68808b94d9ac51fe06daf487008bfaf305ba81e SHA512 68788f6b6700793df2de4fbae85a41fad095f09ac9af717c786305fc1ca6b29438a65d096076b9469dc543a54ce8f72a40dc0f211eb9d517e658ce068e60ee23
DIST pytest-services-2.1.0.tar.gz 20552 BLAKE2B 6359c419591efed553e095e267c24f78f36b152f0eefe21d46742f7c15f05e92a9e86891f99762a3716fef5284b00d07d8d6eb825008dbbbf07e36dc62a7a6b4 SHA512 54a487546a2af7996acdbcd63bfc01626832aa41683617cdd345453cf6518afdf03cb8c2465e1f5d28c88b2cc801ffb0d9d4440582865f899e21fe42ab431ebc
+DIST pytest-services-2.2.0.tar.gz 20995 BLAKE2B a65455d89190d6b63854df7509124c8056c962640972f67210e3b3dbf2d669708e4edb124077cd32e7fe429e884372f4248396377b5d4879d9f7313c3ef7df46 SHA512 48430d6c107626a4e13a8eb16cf5cc3b2068e34869b8a4e3e615fd7a20f3644a028c911211f3de885ffd942cafd3946c313e76ddcf6199bedc9731f7b88c843a
EBUILD pytest-services-2.1.0.ebuild 1192 BLAKE2B 0b01249eaa29b1ed37b363052bce603ee5b5236c872de1e7c90fcf896037ec57d633888445fef215f8767d286f67afb8926980cb37bcdbbf49bbf6ef9fdcb628 SHA512 1d58a79178d31dc5b3846038b5e0dad068aa4b366717c4ea2c9a55bbdae85f18bbbdd435b850ab162c25c5248d370a632bc556bf9a51e653f2b613b2c461dfdb
+EBUILD pytest-services-2.2.0.ebuild 1230 BLAKE2B aa1641741f2dd98046110b8ebcd792a18fa543fed04416ad8022797a7b769dae44d31c8305a830c7c0cd39e850271e7881e4f57782b4d4594a5e98231c86cc02 SHA512 663661875a7a86caf50faae5e4cc518d78d8f62a62ef98bef46882c1185e6e3d95e996f039df17c0fbc6674fd876086949781de4afaa0639edc9aa653c6ca20e
MISC metadata.xml 408 BLAKE2B 84e0589c8c4d813b4542e5d3080ad855611c320c9d5950a08c232c9fa344bca969fa4b23cf6d2b427731d2d30c2f678d33605207042779ea40123c6b249017ed SHA512 de1340d8f01941355ec01b2f92b4e89ad798dd9438e858050861dfb8c139994b5e8fe620b00fcc8133204ba8d265eac36f60ba3bca3a4e0da49332da13b75a9f
diff --git a/dev-python/pytest-services/pytest-services-2.2.0.ebuild b/dev-python/pytest-services/pytest-services-2.2.0.ebuild
new file mode 100644
index 000000000000..4d08d2390cf1
--- /dev/null
+++ b/dev-python/pytest-services/pytest-services-2.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-services"
+SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ net-misc/memcached
+ !dev-python/pytest-salt
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
+ "${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ find "${D}" -name '*.pth' -delete || die
+}