summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /dev-python/pytest-shell-utilities
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest2
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.3.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index 7d04e3054ddc..84eb01fc2d4b 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,3 +1,5 @@
DIST pytest-shell-utilities-1.9.0.gh.tar.gz 79526 BLAKE2B e17b3903b8b3b9c2a8b3d708a1031c5b18beb4741006cec5cf2b8586fb1a86c0034e374927f09786dd036d01ae8811f4eacdaa28053d3205d19bb122211b6437 SHA512 532d82754d0133cc49e8f88e700b1e7469e32a829079536b886358ba15caa18ff30a8ed88e258116ce4302c4220dc986c0f254cef10561ffee81d1e399107dbf
+DIST pytest-shell-utilities-1.9.3.gh.tar.gz 79651 BLAKE2B 1506f7d2fb3b988d55006a8429b6428cb73e969ec72eac5baf944d7e4fc708aaa8e474493ac3e226608c43ece75d2f6070d094f3b656a49bde11bf46a81998d1 SHA512 5ff40043d4f597623bcc61b2c87f00a59fc1882ae6ecda223c82fadc64ae8b5670d07e8e2df54cfcb8b3bdb9483f331a314f4a683760e5ebe843d68ae4067895
EBUILD pytest-shell-utilities-1.9.0-r1.ebuild 1028 BLAKE2B 95d34d8b205d9d8cc76c6671f637f71a489ae17de0b2309b1e1797827ec0e2428d4174d2e9e5dcf2766841dbe075239bc38e560d5613ea9c88fa4577a69e3a05 SHA512 e13507f9d159ba18350d019c22a14b0350acc17e1f76c67d3ae15b14a6d342cce277f5e6ed447153a6ecaf2e193e22faac2800e1c4677dce08d9b06f66dcc352
+EBUILD pytest-shell-utilities-1.9.3.ebuild 1028 BLAKE2B f2af2d38928d44dfc55899dd00ca809915a19f8391ae3e08c4d2b2d0cfb24ffbe41766d879235d0ed2f8ede8a48884cfa0b363d9c11604f198a65565b197d534 SHA512 fb04b0a191da472d27ad4bc68c26002a035348a93dfe53ef8048dee4613e60f0cbb6a9eb4713fbe3e54311a647c84c8d46ff184e066d7961223d48c72c12972d
MISC metadata.xml 532 BLAKE2B 17cc767498152869362024c7cc352f1e0019628a4a0a2099664686285498304eb053c9e6237390dea9a62c7d2471e27c9f4110c41b04902198a46c79a42c8c87 SHA512 2cd69291a69dd5bf7ed6e36ddea2a422287f5c00517d0d1d4e819885ccf975907fd4ef5e2df8ecd0feda89d7fb4b8397265c5ea07c7e5e1e1ed9fdb84afb0b0b
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.3.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.3.ebuild
new file mode 100644
index 000000000000..6a16f052360e
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}