summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-19 04:04:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-19 04:04:36 +0100
commitd895362f98ae63a6ed12cd16d3b3df95d6967f25 (patch)
treee6c8a50e31dc122b10c6dc3d9eee5d6ec6f002c0 /dev-python/pytest-shell-utilities
parent483d7c056fba15727fe24545f93627a1d1e1e2eb (diff)
gentoo auto-resync : 19:10:2024 - 04:04:35
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest2
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.4.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index a05689bee02b..d5f8e79e161a 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,3 +1,5 @@
DIST pytest-shell-utilities-1.9.3.gh.tar.gz 79651 BLAKE2B 1506f7d2fb3b988d55006a8429b6428cb73e969ec72eac5baf944d7e4fc708aaa8e474493ac3e226608c43ece75d2f6070d094f3b656a49bde11bf46a81998d1 SHA512 5ff40043d4f597623bcc61b2c87f00a59fc1882ae6ecda223c82fadc64ae8b5670d07e8e2df54cfcb8b3bdb9483f331a314f4a683760e5ebe843d68ae4067895
+DIST pytest-shell-utilities-1.9.4.gh.tar.gz 79652 BLAKE2B 1f584a86397b772396ce0d0d1bbc270fe6803150259f30d20f11d964495eeb13ca39e97d9681cc3dee638ce0cd7afb6fbaa53a741f4fffc148940762f4c52e3f SHA512 2569c22df69ea0408465670e6bc4a981bf751f7943f46bbd01a89cc20ea713a46f74e50730a0d2cb78c8962b3ca3c221cf7c27f95e4fae6c22a0b1ab1f8c68de
EBUILD pytest-shell-utilities-1.9.3.ebuild 1025 BLAKE2B a3f09567777b05a7833e75d3c233acddebd58e18fd367e1bc30b8719cfb1419ca3213f87a91ce6a716d57af01e366fc6885307eea3df7f391c79fb6c8af00ee3 SHA512 2bdf8dd73fd9a15167701f55d744c41c107b40196357a803b85ea9b01f0955f5f3c6e9abe40144ecb1ebf15b06854b6505e81c98ae59d00f088f06cc08a788a1
+EBUILD pytest-shell-utilities-1.9.4.ebuild 1028 BLAKE2B f2af2d38928d44dfc55899dd00ca809915a19f8391ae3e08c4d2b2d0cfb24ffbe41766d879235d0ed2f8ede8a48884cfa0b363d9c11604f198a65565b197d534 SHA512 fb04b0a191da472d27ad4bc68c26002a035348a93dfe53ef8048dee4613e60f0cbb6a9eb4713fbe3e54311a647c84c8d46ff184e066d7961223d48c72c12972d
MISC metadata.xml 532 BLAKE2B 17cc767498152869362024c7cc352f1e0019628a4a0a2099664686285498304eb053c9e6237390dea9a62c7d2471e27c9f4110c41b04902198a46c79a42c8c87 SHA512 2cd69291a69dd5bf7ed6e36ddea2a422287f5c00517d0d1d4e819885ccf975907fd4ef5e2df8ecd0feda89d7fb4b8397265c5ea07c7e5e1e1ed9fdb84afb0b0b
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.4.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.4.ebuild
new file mode 100644
index 000000000000..6a16f052360e
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}