summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/pytest-shutil
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/Manifest2
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild (renamed from dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild)13
2 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/pytest-shutil/Manifest b/dev-python/pytest-shutil/Manifest
index 2ba801e9a000..32ecdd3b35d0 100644
--- a/dev-python/pytest-shutil/Manifest
+++ b/dev-python/pytest-shutil/Manifest
@@ -1,3 +1,3 @@
DIST pytest-shutil-1.7.0.tar.gz 23497 BLAKE2B e13641491fb4bd448973b8004ac9ded2f9b7c412ea93af7f9206e5fc38ea7554073374116eeefc529d2ae35e8a25e678fef5a27089af89026077a72d11d6016d SHA512 3746c08b17834621a7142ed9d5915b5c348c13367f5b423b258d3471bcb9c9e983c61c25ca936f879b8b82f80512512b7f3ade5555c24a790c72b502e3f3d144
-EBUILD pytest-shutil-1.7.0-r1.ebuild 1179 BLAKE2B 4da7c3e77cc02a21419d7051c9707730831fb4a0bb35b86a56bf1232b17671a4b6fc30279340d9c2fb678c211361407f60029b244357d14efc677967921a816c SHA512 64c6ba86ffd5588f50aa4afa8aa41c05804c30797f75a5a2f0bc44a38a43a435c32209a4c40089c47c732ab075c71032b8a3db15421a037a13e7ef812e0f3151
+EBUILD pytest-shutil-1.7.0-r2.ebuild 1179 BLAKE2B 75e06f8b8b53fc6b6f7be0e27b47457bcca74348bfb950c969e5e1d2fadd1e277d69c0276dde85318006498944aaa8a101c56fcd2b895379f44c4e4577b00c4f SHA512 a0e9544a2652c5bfdbceb6e3c3987ae93356ac734c3d6b10db1111031d273e52c106c498cbdadfb7207ce8b88edbf4045dd55569d7a29dd6acd1eaee479c4748
MISC metadata.xml 732 BLAKE2B afaff2db22c6de29920621f7684dd9cf3a6a070e7d40c2a6ed56fef507fb6dd1ca1b1ac51f106a49c38a556f2c0be244df5c8bae90e71d3ab7d7e1556725d87d SHA512 27c9d4196ec0cad1aa20d3d04c47cc791c9ff19189fd7facf844067c2f81a9c1e00aeeafe2fc65e231fd7039c41eea16c67f6d0f0dcf06386f402ebde03e03ef
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
index cee304ff4f5f..8ee1fa7aea61 100644
--- a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
@@ -18,7 +17,6 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- dev-python/contextlib2[${PYTHON_USEDEP}]
dev-python/execnet[${PYTHON_USEDEP}]
dev-python/path-py[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
@@ -34,11 +32,12 @@ BDEPEND="
dev-python/setuptools-git[${PYTHON_USEDEP}]
"
-distutils_enable_tests --install setup.py
+distutils_enable_tests --install pytest
python_prepare_all() {
- # keeps trying to install this in tests
- sed -i 's:path.py::' setup.py || die
+ # remove unnecessary deps
+ # (contextlib2 is not used in py3)
+ sed -i -e '/path\.py/d' -e '/contextlib2/d' setup.py || die
distutils-r1_python_prepare_all
}