summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pytest-subtesthack
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest3
-rw-r--r--dev-python/pytest-subtesthack/metadata.xml11
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild30
3 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
deleted file mode 100644
index e8a6d10f6c5b..000000000000
--- a/dev-python/pytest-subtesthack/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pytest-subtesthack-0.1.1.tar.gz 2410 BLAKE2B 3d41950ad46bb07da145db7f88eba7eb34a2bbb99273f47d2443cae5ab0e11737f1c2fe81bf473180178b2ad9e55b252c7717846f1b010cc58fb1bf61380d003 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f
-EBUILD pytest-subtesthack-0.1.1.ebuild 806 BLAKE2B 9fdc0707312f101c37e593689af8a756417714d6013f6eb5c886d30724d2748d1b71ea8744d0973e764104012cefa09d02f989ab86ee49fab522453e5746b5a9 SHA512 1e5e6c65aa77268ae0cc47c8694249f0f9c79fb0b0fd1baaa9bd2f476fcc6cb44b37e692a3c421a61a967454b5c37f6f857d0f8908fc9ce1c75c9d1b462de426
-MISC metadata.xml 321 BLAKE2B c9b07273af601a4874a8e2790c84350cbd5ca4218c4604de564b8a714a946106ef74ee744bafff29f160a4ab3bb6abd35c49a66cff74c83698a0a6f57b843bd7 SHA512 f1c6901c39e0eaaf79917b0699ae5d7dc9a94b15ed2db4ff08f0e3f2bfdaa567e3848474934bb4d8aafe56198536a4ff8f5a6b4379c2238ee20e4a718bfd9a58
diff --git a/dev-python/pytest-subtesthack/metadata.xml b/dev-python/pytest-subtesthack/metadata.xml
deleted file mode 100644
index 6979d31debc3..000000000000
--- a/dev-python/pytest-subtesthack/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pytest-subtesthack</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
deleted file mode 100644
index 5213ff6241fa..000000000000
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit distutils-r1
-
-DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
-HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
-# pypi tarball misses tests
-SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
-}