summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/pytest-subtests
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest3
-rw-r--r--dev-python/pytest-subtests/metadata.xml11
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
new file mode 100644
index 000000000000..20a8e06b5665
--- /dev/null
+++ b/dev-python/pytest-subtests/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-subtests-0.4.0.tar.gz 9673 BLAKE2B 780fbbdc6d4ac88c87002ee14323a0dd1036ab3dadc14b79ef11982459c60635add77e97575521ba0bda61317582e090353b427d945eca7198e294eb3d895240 SHA512 00302f47d1699e053314b6b4eee7c84a04fe0f51f287e338374bbd518c7d245d839ea0f1ccf50d4f35c86138cf6ea36da26e67bf41295205fb38323f2ad89f89
+EBUILD pytest-subtests-0.4.0.ebuild 787 BLAKE2B 3158a666a2bbc34ca6863ba509c919c8a90eba111f75fa975b12180a304a249cc276c21bb0be1a3fd85af4cc1e860fd0f19e013bdc5935231fb4322bc23305eb SHA512 005a6cf11275a608df65a97b5df07cbad55c16799769da09ac1f72c069b74aee760ec90ccb06c62663d8fadb7d7ef0b51225e0aa9d55364c18dc36eb6bcc326f
+MISC metadata.xml 362 BLAKE2B ceee0c128aa3a64a2693c2b2a8277a2a5f985f9ccfb00bde0c56a32a3714fa0112c85e46b93d4815b1d53eee63ac5ce01673f7e97d3485cd973f3ab3052daff9 SHA512 2746d62eaca67e02a0c8e1a65892fc7447e9ea6dc1767e544642a6e57d43b6acdc0ccf3a7271f1cfdc5295b26e3518594432e968e219ca2abba03ea4e59cf5b1
diff --git a/dev-python/pytest-subtests/metadata.xml b/dev-python/pytest-subtests/metadata.xml
new file mode 100644
index 000000000000..04c1351756da
--- /dev/null
+++ b/dev-python/pytest-subtests/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-subtests</remote-id>
+ <remote-id type="pypi">pytest-subtests</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
new file mode 100644
index 000000000000..9df48e8c3010
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}