summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pytest-system-statistics
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest3
-rw-r--r--dev-python/pytest-system-statistics/metadata.xml11
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
new file mode 100644
index 000000000000..41a79fe0ded2
--- /dev/null
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
+EBUILD pytest-system-statistics-1.0.2.ebuild 1277 BLAKE2B 2874b460e755830f2644bd071d6f5336a8fd906825ff350c7a5da8f3cffdd740b6c86c9289761c2b02b6381b9642b2f45ac5668f93f3f5addc8afcd3dd0784f6 SHA512 6804ab2305f8a9cd8ee90ce669e9906b5e58fb90c77ee494f0197331edaf5f09cb0a91ceafabe3a0da4e2ec0f4ad278798b13a77c6d5196c6ce2e81de1913bd7
+MISC metadata.xml 337 BLAKE2B 00bcf31ed6a7b0b94fe3bc0f3031d64bdd682be4797a4f2878ac0d66012d8c026a7295c923f9081f9e7b1b2dc1fd7c6dc7a4e33dfcd97f80785a737815979313 SHA512 a28c702734f0907afdb667a42e8d2672ab938bb4802f4e55e69de872694176b5424cd7073a9b2caee7dbe856fa511e41447ed30e49cc64d053a14b9ad830766a
diff --git a/dev-python/pytest-system-statistics/metadata.xml b/dev-python/pytest-system-statistics/metadata.xml
new file mode 100644
index 000000000000..227706a29106
--- /dev/null
+++ b/dev-python/pytest-system-statistics/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Patrick McLean</name>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-system-statistics</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
new file mode 100644
index 000000000000..27a2d008b30a
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -k 'not proc_sys_stats'
+}