summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
commit94ead5b3c01213a82c9b72a2df165452421db42b (patch)
tree8a48ed4d21de4204607288d00e68a671bef1e8f8 /dev-python/pytest-timeout
parent418459f7de9eb29d6db8b61681f39c467d9600e1 (diff)
gentoo auto-resync : 09:10:2023 - 00:04:30
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest4
-rw-r--r--dev-python/pytest-timeout/metadata.xml1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild41
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 4e13f70d5514..ff66dd6758f3 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,3 +1,5 @@
DIST pytest-timeout-2.1.0.tar.gz 18386 BLAKE2B 1c84b67e8d07056f9c5b188e467832d4aa292ce1047da6cb13b2939962d2599853db134b16ff3a1a953cbdc1c1772be961eadc9925b32f8dbe514938ede90d40 SHA512 5750e5183669ed9b83fbb76bd7fc9fc1f5f6eef3d9b675dc44f6c7edfd2c6d15739d71e845ededaa192c93da73026ac3376a3295be9f7d3f3eac325660ce7bf3
+DIST pytest-timeout-2.2.0.tar.gz 16391 BLAKE2B 550b803ed4a64ab0fead7f6e61297ea6bfc6e59988998c5383fdccdebb3664fe9f6651314bb1a439f6431e844bb770feb50bedcabd568e4dfea7526d8c328dd7 SHA512 11a0c4e958b324bff3e149bf2a7dc5bf6ab6549405d5061856f8f1ad0e43df1cddce83df4c804b717276bfbcfcf60ee6b400625d0f4e4e73c98785146c22164f
EBUILD pytest-timeout-2.1.0.ebuild 794 BLAKE2B 5191792a1dd44fd7e74dd0a1424ef2539321caa21bfea60bf74a421286e742e75c4e5028fa06c630ad8ef049156aa1135f97bad056d8ea6ba608a02f6ff00363 SHA512 8873202b09704d0bebd197ee3cac5213c59ce70ab430cc94b7f2dfbd31b1a30464204ac34dd6731ae0ccca582a5bdb307a91dfee0bd5d2cba3e22d7a4f104448
-MISC metadata.xml 353 BLAKE2B 4865119ec7c91f6d9ac1ab4ce5b1cb73b784f29f7efd669c629062cca2d433eaabb51af1d0ddb3275d414a99413eb8aa76c8639d484c7846ea33c4f53a013bad SHA512 764118890125a80df18e5d9a1bbf6bb35261c0cbcc04e6c9c67ee7b307cdbc31979b831910022a1caef97deee6830d7236f258f524a95a9494229dcd4a14c8ad
+EBUILD pytest-timeout-2.2.0.ebuild 1019 BLAKE2B 82654483fad3d2e9c5fb0a9dc855866f269a5564a5a7f36c7489aaaff324c24bae203a90b7ed531be5ac344b64c91f4de0740991b5bf53a9a0aa893a5dc5b96d SHA512 3a4d9c6807d4d99dcc650c63f88164cf5a73b84c31eaac2f757929548afa4c26c22bc0125224e09a5d4bbbd82b87f5df25f61597f5c6993cd9882fae88d76dd1
+MISC metadata.xml 420 BLAKE2B ff56de441243acbf2c7332acf224c8f64427378a8cd5f56c040eca1bcaae467459d8ae09409a963d0053a95035a4e7cfcda067d5be78bcd24ba222b2ce56d6f4 SHA512 c6b4ebdd5bd59452d0952e50526ca9b7cb5b88b12d989947a4775d60cdc9315d594ca7c37cb17c0cd4b2708d08db625f678fd577ac9031e0b0e6dbb364a6ad3a
diff --git a/dev-python/pytest-timeout/metadata.xml b/dev-python/pytest-timeout/metadata.xml
index fae0e54ef9b4..7f42025636a8 100644
--- a/dev-python/pytest-timeout/metadata.xml
+++ b/dev-python/pytest-timeout/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">pytest-dev/pytest-timeout</remote-id>
<remote-id type="pypi">pytest-timeout</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
new file mode 100644
index 000000000000..0201b80b5b46
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-timeout/
+ https://pypi.org/project/pytest-timeout/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' python3_{10..11} pypy3)
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
+ test_pytest_timeout.py::test_disable_debugger_detection_flag
+)