summaryrefslogtreecommitdiff
path: root/dev-python/pytest-toolbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/pytest-toolbox
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/pytest-toolbox')
-rw-r--r--dev-python/pytest-toolbox/Manifest3
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild33
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild5
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pytest-toolbox/Manifest b/dev-python/pytest-toolbox/Manifest
index ae6dcc3a8357..66eecbb71f1b 100644
--- a/dev-python/pytest-toolbox/Manifest
+++ b/dev-python/pytest-toolbox/Manifest
@@ -1,3 +1,4 @@
DIST pytest-toolbox-0.4.gh.tar.gz 8594 BLAKE2B fb1f19513e9e4b191c3eb995cc5e9445bc9f19affef87350d925c5465210c4de945b91120f86664c1dcf02a638595a7725cf88e3244e377ae77558c70d65643a SHA512 ed27700ff77cd607be808142cc310cd2b7461e55b3f8352d304ef8ca6c5e6c060c67a63238a1025407868ab8e229c4a16eaaa56aa75000159762001accb67752
-EBUILD pytest-toolbox-0.4.ebuild 680 BLAKE2B 8495859834fc6d02e4d448c751ffbe225ba30c64bbef7257f36916937f8ac8f40ab57dd708d9f49aa03ff88ad543767b7d30aa46cb6ce64c6e8e488ce683c086 SHA512 1353021b5552476bceae7cb21aeb9f472aba815546136b01845daeed4c291fdedfb26c52fee6c560e53ee6f39340b5bb679c1259d63c620f1adf9b4f3bbe401b
+EBUILD pytest-toolbox-0.4-r1.ebuild 744 BLAKE2B 12e88f4d1553ace5943f3c393942e2280a46841bf358b22cc77890e5b4592ff6a9671be51ace964ec3e760555badc57fd4ff383eebda1f42022457ba000e5450 SHA512 228d98f902b76be5c5c8e2e0615439da0bab33656355bd3d0c3a3dded02f583f5eaec95f9d9caec811a41e07d517b19fa7eaa850a9dfe451924cac6b71e51c13
+EBUILD pytest-toolbox-0.4.ebuild 692 BLAKE2B c51849da62225a374485865a58bf249ebed8a754fd45921930b412f8e5933c7ac28f91374c4fe41b774d79818fa595ccb28a25a59eebbb03d7bb1021962f5542 SHA512 9067d07543bbe177eb8c756c79a65d9071783c9e020098b80e68fa1ff8c7e03ccf7e5744ebed7c61f4a52d4c5f22d09895bd558c9cf1e6682d634488a9fc0eca
MISC metadata.xml 395 BLAKE2B 5d6c5c889169be1f1e05eadc0cefcbe90d51c4c7400aef7d1c653c4a018f5288384c30b7f58d8502d0c1ffb2c07aa08a81cca7e4d12b5df7ef344fabd13ee7a5 SHA512 bfcf70da768f5a66edc1ed98211ced383bac3ea1ca2313efc7caac197aeeba1c988fbd738b7118afdc775ed30b43ee8af42c9c39da82eefadb88e87802f6f8e4
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
new file mode 100644
index 000000000000..692fb61b5729
--- /dev/null
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Numerous useful plugins for pytest"
+HOMEPAGE="https://pypi.org/project/pytest-toolbox/ https://github.com/samuelcolvin/pytest-toolbox/"
+SRC_URI="
+ https://github.com/samuelcolvin/pytest-toolbox/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
index 39e227ddaa46..373a1f591ddd 100644
--- a/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="Numerous useful plugins for pytest"