summaryrefslogtreecommitdiff
path: root/dev-python/pytest-twisted
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
commit328b082fd6fb193da715f61a92ff9366ad562a34 (patch)
treebb1cb21fc0cdf0377ed571709e5ff4460f159a76 /dev-python/pytest-twisted
parent06617f385b21ef2262c88f17869c15c424e67d21 (diff)
gentoo auto-resync : 19:03:2024 - 12:49:59
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest2
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index 0546564d35eb..0136b4c69b82 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,3 +1,5 @@
DIST pytest-twisted-1.14.0.gh.tar.gz 16234 BLAKE2B 1f0470893135127111194dcb726e5c16c8ce6911456eae7068035a001010b2513f5b1d7507c84f8ebf183042144c3cec3fb4fd1f060d987f5e1f3c053f29ed0e SHA512 d3c1b7320f87bd32bec992b807baf235c13e5595c93895eb7df91f709d7ab92dbbc30a47f4341477d7ba9541958efa1d4ef7d355023050747b401bb541314bc9
+DIST pytest-twisted-1.14.1.gh.tar.gz 17114 BLAKE2B 36b851b734acc03919dc03842d942d205468375d9318d4ce4f880532fca29d31354125fd2ab8149a50bcf29e46ec812898b7167e34c0fa1276dcd5c2aa36ccd1 SHA512 d5b6d629ed3cf7ae1537e76494fa7eb4bbb9767cbc50d97a5657c668b381f39236acc6224b3754d62e2cccd4dff7e6161265ddc6a939f0488cef53eeade0eae9
EBUILD pytest-twisted-1.14.0.ebuild 1232 BLAKE2B 79b6d049e712d4c894bd5fca209ff277ea84d6977b2fb2ec6a2d6299d75be46e73ed4a5aec6f514efec2a4e5f126011fbcb93086b685b710547a881a0c21f569 SHA512 98051e0f05609659f8b1c80a496caf68bea43e16ed040242984e55efd3e946153be9b559aeebabfd392023b58f376a8e50453e96fecda63fd7b87fccc82d3c56
+EBUILD pytest-twisted-1.14.1.ebuild 1301 BLAKE2B 993165a772feb82040481f7b9e661bb618b34909d657bcac0243c173838b814174c21733c6d78ecb1a11f312c5795368e868e09930f35267501253f8e30c1351 SHA512 192b4a1b97c60a4394974116d983ecf61c8724641dadeb835e39bacdfe9ebec896c60713e7208bdf8d6c25a60d0f4de2dff792940eca47116bf71a6e0897422e
MISC metadata.xml 486 BLAKE2B 4ba2590c5d294332345eb3a4bffb129efbb9db6f3bea8d170a3edc8910353884f0fc0381b8a9c291284be8b0d7f423dcef1e93db75596bf2cf7a9fe2c02141a8 SHA512 3e47cd9d8604de7f4088372a9a0b33084eedf24c1553f21520c940fc474ad51733b03af86aae399c9724dbebb70a7e6fe03a4003d1a8ae09316966d7ffddfb24
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
new file mode 100644
index 000000000000..71996ceec517
--- /dev/null
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A pytest plugin for testing Twisted framework consumers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-twisted/
+ https://pypi.org/project/pytest-twisted/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-twisted/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # If we let pytest-twisted autoload everywhere, it breaks tests in
+ # packages that don't expect it. Apply a similar hack as for bug
+ # #661218.
+ sed -e 's/"pytest11": \[[^]]*\]//' -i setup.py || die
+
+ # https://github.com/pytest-dev/pytest/issues/9280
+ sed -e '/^pytest_plugins =/d' -i testing/conftest.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_twisted
+
+ epytest -p pytester
+}