summaryrefslogtreecommitdiff
path: root/dev-python/pytest-twisted
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
commite810ac4a0e6af9f763f4433863042b34609075a7 (patch)
tree6fe0b3ff24f3b875be1564e273049c1e301d205b /dev-python/pytest-twisted
parentc218398bbbe70a616790cf146c28c1066b9284bf (diff)
gentoo auto-resync : 10:07:2024 - 12:25:06
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest2
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index c35aacbc5357..c34a557575fd 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,3 +1,3 @@
DIST pytest-twisted-1.14.1.gh.tar.gz 17114 BLAKE2B 36b851b734acc03919dc03842d942d205468375d9318d4ce4f880532fca29d31354125fd2ab8149a50bcf29e46ec812898b7167e34c0fa1276dcd5c2aa36ccd1 SHA512 d5b6d629ed3cf7ae1537e76494fa7eb4bbb9767cbc50d97a5657c668b381f39236acc6224b3754d62e2cccd4dff7e6161265ddc6a939f0488cef53eeade0eae9
-EBUILD pytest-twisted-1.14.1.ebuild 1294 BLAKE2B 17591b68a9ce12b2398a7ca4592b8b95d22a9f4475f67a1367fd2ddcf46f856868edecfa890b9688e76675715bb09bedd009f9b7ea63d6bf0a3904afbae91fb1 SHA512 af2322832ababc1f1ea28e545eb4f64d4f523e9ae400008cfdc1cf8a86ffb7d441727bfcc394604fc2b73b834a025a1b23482638bccfccae9f2737c3f752f044
+EBUILD pytest-twisted-1.14.1.ebuild 1472 BLAKE2B e22906e3e33582187978a04289e63a0036a4bf92a6250b0c1037b3be554692acfe891588d4add8b14a17c229653d5146a4cd3fef4850e709b7c65287337df60e SHA512 eb416f4d78ec5b3ce398c54c4192c2b52dcd6b05bf908f709f953d4a42f9261baf8ff16727339d5727d715eb02c1975619e20f5ff86757803f119f94d6769167
MISC metadata.xml 510 BLAKE2B b0a57f26f53646876843a2d19d2eae54f4ba393afddc58dff646e5aa0a755c0920223d572fd4fcf5d6540c1512e52f798045424d09713aae15e4d4310cc3d10b SHA512 0faeb8637414016721807155ce0546912cc6b9507ad21936491397efa55108e60c5973753941b11d61070f35540113470e533f4e233a1925183d3ae77d2d4949
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
index d9db61f8173e..f90693d8ef2f 100644
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -52,5 +52,11 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_twisted
+ local EPYTEST_DESELECT=(
+ # regression with pytest-8.2
+ # https://github.com/pytest-dev/pytest-twisted/issues/176
+ testing/test_basic.py::test_async_fixture_module_scope
+ )
+
epytest -p pytester
}