summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
commit22f5aa1d3324a28622ae4bc828ee77ee079edbb8 (patch)
tree9dda4f0e2d4085105a470d17b1d6dc04cf4ed6fe /dev-python/pytest-xdist
parent8e2875c48ca3030fa53717c6fb773b63eba7ca6d (diff)
gentoo auto-resync : 13:03:2023 - 06:14:36
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 95d456b92e61..12128354553a 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,5 +1,7 @@
DIST pytest-xdist-3.1.0.tar.gz 71977 BLAKE2B c29622377743aec0a90f0e92af866a63106b9c37abee379222fd2b5c40f0607c33010bb5d2cb5212fc90a438d787ecb435f07c31e0db7a10599696c33b309a32 SHA512 884cdd85754b36338666cbdd71575ef18465730cfc4ab7333b93aa46823c1dc33e8055117241f4c87e1b8c82492881cc0f91ef1bb2ddc164aa00bfa1e5e2d245
DIST pytest-xdist-3.2.0.tar.gz 76199 BLAKE2B 462d6af54ba599f506a51ae2e91ab0c08fdb8a6b3e47ba4541c0fe2c19a9aa8a38dee0621e130d23a2daecdc9509b1020eb05d550a50d6de233e185a8108872c SHA512 dd22c2e525681ddabc1df75e8eadcf0d3c52936cefafb7308771e37cfe9023cb4ecbbaf4e437668666f5319e379e7b6c5c7665912b59c5d10890c32da7546433
+DIST pytest-xdist-3.2.1.tar.gz 76362 BLAKE2B a5cea5bab1176554bd0d1ebfff5400f60bd43964ae13c7f77ad77fc257db32ba0a0d6f2f3ec16211e48852a6bfd02a0949d618c7f2f6a8da11dd2843d88565a4 SHA512 ea42bea8b4df3d77ef680cba81f76f9f79d0ffcaad6f5f879cc82c53203d36ffe26f233dd6c5d1cbea22b43d257f0f4e6be793116bb281956316c44fc412f9b7
EBUILD pytest-xdist-3.1.0.ebuild 1123 BLAKE2B 7b511dc74ad8af94061a987c7b890c9804a2a962394138679f674be6213922d3a5f31be4230f4dbc1c617f8b8b1538e1edb30fbd2b57a21ce7ff12b77cc16974 SHA512 8a7129d190b1cfa8447f1c9e5fce9536d87385e75828333e00330a698eea98f22f96424268f96a9eddbe3d8e5aadfeb03f7f1de2782a271f607c4d1eee849c95
EBUILD pytest-xdist-3.2.0.ebuild 1104 BLAKE2B 18604032d8eeb812e4a005794eaeed43a3ac6433df75f877cae01929306eeed51abb17f55dbfa079c759f34463cbcbcb43fb0851328e1c24136594c314d0aa8e SHA512 22094bc669a552acd1677e16e398db1d64bb57f6b82a826b3ddff86edeaeebdd9de53ec787baeaf8d1125d676e53c4d98fc6b5c083b3e327aa41171a5738dc62
+EBUILD pytest-xdist-3.2.1.ebuild 1104 BLAKE2B 18604032d8eeb812e4a005794eaeed43a3ac6433df75f877cae01929306eeed51abb17f55dbfa079c759f34463cbcbcb43fb0851328e1c24136594c314d0aa8e SHA512 22094bc669a552acd1677e16e398db1d64bb57f6b82a826b3ddff86edeaeebdd9de53ec787baeaf8d1125d676e53c4d98fc6b5c083b3e327aa41171a5738dc62
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild
new file mode 100644
index 000000000000..c3bc7d37a95e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}