summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
deleted file mode 100644
index ca8f808077c8..000000000000
--- a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
- # Upstream's package mistakenly includes __pycache__ directory that make
- # tests fail.
- rm -rf example/__pycache__ || die
- pytest -v || die
-}