summaryrefslogtreecommitdiff
path: root/dev-python/pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /dev-python/pytest
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-7.2.1.ebuild105
2 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 0e51a9de977b..194c5efbfe56 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-7.2.1.tar.gz 1301901 BLAKE2B 3323e4d0dc95708733425aba808a864816d73a1d67f2f3048ab516aff9c2e5ddafab67d8596ad5693254c906e9714508e7faef591c89592fcf071698b3dbdb30 SHA512 3f09ccda91c0f14156cf558abde880279838d1a61c8f7e7138ea9fcd59be0577234da2f30410959641fd5a17490c713c0008ce2ed4b4c57196267fca69714061
DIST pytest-7.2.2.tar.gz 1320028 BLAKE2B 51742872c03ccba3b305fdb3015a1c2a8f7dbf2988f267ea13e2add438ae52e2d5a6cace483525cf37f7ea72454bb346b81196c6e043dbbc3e5c0c8a1a365ed7 SHA512 100e06a9eeb9f3f5fc4f61ab10cd83a80280dc411fddde9361f101b77e69f8600d2f4846f8611a47f441724cf8ffe6bc2cae4b75703f9b48cacf0eee83eaf3b3
-EBUILD pytest-7.2.1.ebuild 3581 BLAKE2B d630c83f102eb9db560ed85b47423e4f023506ac2a76a28d9a1a230b8090182fcdb5d093d0a59c0e470ee28c585ae8da06d09aa884104abd0820b00199823cba SHA512 cd9f53226fc9c09431000b941a6ec89f5d01aa9c3b0a7dd0cba9bca429094963aa6bf92843dd767b1428048b7de009ad802705baae995c90e715901dec758271
EBUILD pytest-7.2.2.ebuild 3534 BLAKE2B 3ebe924325f6b1b90cff020b0fe2332064cb8c92409fff06f3f6bd3a2f55023d757469ef411c9b5e71ff16e3c181228a629c0e237608027d70d852ba27128886 SHA512 5fe7a1d3a9aa6c91cac288c7e4e0299f527bd2717c67c84f9d08b1af5964a5e9a95fcdc620806efd869b8032e68585aaa4845d00e8dc6373fc3af74c77334cc3
MISC metadata.xml 391 BLAKE2B 48d31ecb4c8b171ee4e84a58399211368ddc00dfb5dbe0999f96e03d744294cd4fd5263e90600c93d1f13c7da21052faef84b6d0d56709f3559e37b3392ca31d SHA512 6e9caa57eda23995d21df6f52c52d5868e1ff56abb6c1351ffc0fe14b771639473481a2630e659caaff83f0255379aa2d012175af52a0de41221b27d3ab2f425
diff --git a/dev-python/pytest/pytest-7.2.1.ebuild b/dev-python/pytest/pytest-7.2.1.ebuild
deleted file mode 100644
index e370a608f05b..000000000000
--- a/dev-python/pytest/pytest-7.2.1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{9..11} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="
- https://pytest.org/
- https://github.com/pytest-dev/pytest/
- https://pypi.org/project/pytest/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/iniconfig[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.2.3[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/argcomplete[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.7.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/xmlschema[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-src_test() {
- # workaround new readline defaults
- echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
- local -x INPUTRC="${T}"/inputrc
- distutils-r1_src_test
-}
-
-python_test() {
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x COLUMNS=80
-
- local EPYTEST_DESELECT=(
- # broken by epytest args
- testing/test_warnings.py::test_works_with_filterwarnings
-
- # tend to be broken by random pytest plugins
- # (these tests patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out)
- testing/test_helpconfig.py::test_version_less_verbose
- testing/test_helpconfig.py::test_version_verbose
- testing/test_junitxml.py::test_random_report_log_xdist
- testing/test_junitxml.py::test_runs_twice_xdist
- testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal
- testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal_count
- testing/test_terminal.py::TestProgressOutputStyle::test_xdist_verbose
- testing/test_terminal.py::TestProgressWithTeardown::test_xdist_normal
- testing/test_terminal.py::TestTerminalFunctional::test_header_trailer_info
- testing/test_terminal.py::TestTerminalFunctional::test_no_header_trailer_info
-
- # unstable with xdist
- testing/test_terminal.py::TestTerminalFunctional::test_verbose_reporting_xdist
-
- # TODO (XPASS)
- testing/test_debugging.py::TestDebuggingBreakpoints::test_pdb_not_altered
- testing/test_debugging.py::TestPDB::test_pdb_interaction_capturing_simple
- testing/test_debugging.py::TestPDB::test_pdb_interaction_capturing_twice
- testing/test_debugging.py::TestPDB::test_pdb_with_injected_do_debug
- testing/test_debugging.py::test_pdb_suspends_fixture_capturing
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # regressions on pypy3.9
- # https://github.com/pytest-dev/pytest/issues/9787
- testing/test_skipping.py::test_errors_in_xfail_skip_expressions
- testing/test_unraisableexception.py
- )
-
- epytest -p xdist -n "$(makeopts_jobs)"
-}