summaryrefslogtreecommitdiff
path: root/dev-python/python-application
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-application
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-application')
-rw-r--r--dev-python/python-application/Manifest3
-rw-r--r--dev-python/python-application/metadata.xml29
-rw-r--r--dev-python/python-application/python-application-1.5.0.ebuild18
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-application/Manifest b/dev-python/python-application/Manifest
new file mode 100644
index 000000000000..ec36e8e60527
--- /dev/null
+++ b/dev-python/python-application/Manifest
@@ -0,0 +1,3 @@
+DIST python-application-1.5.0.tar.gz 43552 BLAKE2B d36c3b0af9766936dae4c45452278e7f6b49dc830d1490fd97e455596b6564ac24b1c78da76237ace873ffbbadb3d9d4975728ec28e82bc39e4b12df2d9519bd SHA512 9bf683a88bfb11ab5cf86b2d1ef86e22cf6fcb6004f0059b1d3cb2e1cde46827ced57a1cdd313c1d48dbd1ad610e9d36617619f79af748c55c517089720cb2b1
+EBUILD python-application-1.5.0.ebuild 391 BLAKE2B af56191a8ccdfc5c5cb14fcdf7fd11a7d473f6be8f7a3737f95e86e943a8ef45789a013104fd0c8527c67994ac5e18f597430e3981c21071d63eaf1dab8bc5ec SHA512 2e09c0d0378b87ed55c5b13d6505bc9a44b91a411a7bd9fb9b0c02b00f38daa9d147d9d47a849f535af30d48fd8e177325a8630d673be1394bcd8f5fa48dfbfc
+MISC metadata.xml 1284 BLAKE2B c48df5628c15a6d309dda0d21f36c699240a9d903fc21b37c8cc464612e19c3417a249d4a1670add02d66f3f7bb10809a487e7cb94ba59c0caf5eefe3ccd424d SHA512 a40bb81f3a76e9d3012ce5aa6a49f0671c5449856afaeb278f4b7bd32eceaf63cdce667d81385fdcab7af4180f80e46f9123a71140829e5f2d6388b73d919fb1
diff --git a/dev-python/python-application/metadata.xml b/dev-python/python-application/metadata.xml
new file mode 100644
index 000000000000..bc01efe4aaae
--- /dev/null
+++ b/dev-python/python-application/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package is a collection of modules that are useful when
+ building python applications. Their purpose is to eliminate the
+ need to divert resources into implementing the small tasks that
+ every application needs to do in order to run successfully and
+ focus instead on the application logic itself.
+
+ The modules that the application package provides are:
+ 1. process - UNIX process and signal management.
+ 2. python - python utility classes and functions.
+ 3. configuration - a simple interface to handle configuration files.
+ 4. log - an extensible system logger for console and syslog.
+ 5. debug - memory troubleshooting and execution timing.
+ 6. system - interaction with the underlying operating system.
+ 7. notification - an application wide notification system.
+ 8. version - manage version numbers for applications and packages.
+ 9. dependency - verify package dependencies at runtime.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-application</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-application/python-application-1.5.0.ebuild b/dev-python/python-application/python-application-1.5.0.ebuild
new file mode 100644
index 000000000000..0dd28d0ff556
--- /dev/null
+++ b/dev-python/python-application/python-application-1.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Basic building blocks for python applications"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"