summaryrefslogtreecommitdiff
path: root/dev-python/python-box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-29 06:30:44 +0000
commit0e12f8e53cdddba84b0eb27dca59153e2cf52309 (patch)
tree8dec970370295a71970b82457ae1db36dbbbd07c /dev-python/python-box
parent72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (diff)
gentoo auto-resync : 29:12:2024 - 06:30:44
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/Manifest4
-rw-r--r--dev-python/python-box/python-box-7.2.0.ebuild58
-rw-r--r--dev-python/python-box/python-box-7.3.0.ebuild2
3 files changed, 2 insertions, 62 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index c9554fcd654a..5485d4a52454 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1,5 +1,3 @@
-DIST Box-7.2.0.gh.tar.gz 87699 BLAKE2B d6f033919e5451adfdcb0c14c28a47e25b619eb531280a39b68912179ad3a21638d4fadd6dbee2b09bc445b1adc2dd31e042d1e816dc5fc36098ea5eadab8a30 SHA512 8f2ec95a0539c8000d08353eccd66dd9de4049408b0cef9095f3bf98486424214e1d47ef5c408e425c5c2958652624efa512701138d91d51356f07795c508b9f
DIST Box-7.3.0.gh.tar.gz 87791 BLAKE2B eba82f4fa083f2f7725547254143d86d034d1dbf0ad540eb4cef8eb387846053a44a7b7dc6b94878a124f98336cade4c6a64c89beb779e5db6008393b721ecc9 SHA512 9425dc339abac6649f9e78b279720ce191559e1629eb4451fc1a63495df1d5c64bf20a339407bbfc6f8e64d9def4accf312087958880a5300c83369ee9d6ceb4
-EBUILD python-box-7.2.0.ebuild 1121 BLAKE2B 1732e445b76fb23aa9a1b022385d4d6088d1603c6015fadba226d62f718016b93f755aea127edfdf44d34867cdf05febea9dacb537baf810bc6c87512a4eea43 SHA512 12afcd3bcde9fa28efd1c83f27c1f79b463287c997e8f3db49c478ae3b795dd773162f8c779a301f385e7782deb2546153428bdf45db26e45af1dc5acb765a26
-EBUILD python-box-7.3.0.ebuild 1122 BLAKE2B f58c059d36b76842afd0c30ef6751912c4f17edf24faaab2f07368a7c4ec7cc4a77106f5bcf816fc524286aed2a5a2ef3804278934b6a7105c7317a7b330c323 SHA512 395433f4fd8e8431febfda3306062da9778fd74690d276c41cb46a0e3165309f340cdac9ce02e024181dc63ee56b57bf99d37873d9b54d49a1452fca772aef8a
+EBUILD python-box-7.3.0.ebuild 1121 BLAKE2B 1732e445b76fb23aa9a1b022385d4d6088d1603c6015fadba226d62f718016b93f755aea127edfdf44d34867cdf05febea9dacb537baf810bc6c87512a4eea43 SHA512 12afcd3bcde9fa28efd1c83f27c1f79b463287c997e8f3db49c478ae3b795dd773162f8c779a301f385e7782deb2546153428bdf45db26e45af1dc5acb765a26
MISC metadata.xml 455 BLAKE2B c87617c0445d56b0b2615ee0727bd18202ff2aacab347e0ddd6e26c2c4a7ea2ec484a01227c7a5a7deec870aae3475422ab4940b15b08401209936d004866c26 SHA512 3d4f528845543f82e21bd97cd4eeea8e52da76634832640a430fe1764f56442a9e909cf14a0426eb64ac64c77a93d619c03731678d0beeb758720261a374b45d
diff --git a/dev-python/python-box/python-box-7.2.0.ebuild b/dev-python/python-box/python-box-7.2.0.ebuild
deleted file mode 100644
index 5ac6f4364422..000000000000
--- a/dev-python/python-box/python-box-7.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-MY_P=Box-${PV}
-DESCRIPTION="Python dictionaries with advanced dot notation access"
-HOMEPAGE="
- https://github.com/cdgriffith/Box/
- https://pypi.org/project/python-box/
-"
-SRC_URI="
- https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+native-extensions"
-
-RDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="
- native-extensions? (
- dev-python/cython[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- if ! use native-extensions; then
- # a cheap hack, extensions are auto-disabled if Cython.Build
- # is not importable
- > Cython.py || die
- fi
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- rm -rf box || die
- epytest
-}
diff --git a/dev-python/python-box/python-box-7.3.0.ebuild b/dev-python/python-box/python-box-7.3.0.ebuild
index 2fc0ece6b850..5ac6f4364422 100644
--- a/dev-python/python-box/python-box-7.3.0.ebuild
+++ b/dev-python/python-box/python-box-7.3.0.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="+native-extensions"
RDEPEND="