summaryrefslogtreecommitdiff
path: root/dev-python/python-box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
commit6d730aa8064fbab6cc54447b6ed0e60b99c13256 (patch)
tree8c303cb48dc49dd218b79708ca71904653c5f831 /dev-python/python-box
parentcb2f73d10494730ba590096a1f24ebc6d0d61a9f (diff)
gentoo auto-resync : 17:01:2025 - 06:41:55
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/Manifest2
-rw-r--r--dev-python/python-box/python-box-7.3.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index 97f49ef65953..912fb114caaf 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1,5 +1,7 @@
DIST Box-7.3.0.gh.tar.gz 87791 BLAKE2B eba82f4fa083f2f7725547254143d86d034d1dbf0ad540eb4cef8eb387846053a44a7b7dc6b94878a124f98336cade4c6a64c89beb779e5db6008393b721ecc9 SHA512 9425dc339abac6649f9e78b279720ce191559e1629eb4451fc1a63495df1d5c64bf20a339407bbfc6f8e64d9def4accf312087958880a5300c83369ee9d6ceb4
DIST Box-7.3.1.gh.tar.gz 88055 BLAKE2B a222af827b9774d482b335ec4854429ace81144d11622dcc55cbd648e6c550d086fc6dbcba885a882a56cc9d4d43808b0bdc65ebd641984f109b797172426c78 SHA512 cf6ddc38fad160ee651f19da5d1b24ce7e396590de490aa0874de139888128a1c673228acbe5a3a1b68deeabbe372c3be20f5b2bfc1c576bf1f827d8a042707d
+DIST Box-7.3.2.gh.tar.gz 88125 BLAKE2B c5f1fb1aa0ebad873869e401ebf74ba9dd99dde79585248f2f91c11d0f8bbf673447b2a521e209452c706e7d3fc8eee0b1e80e37f48ca5d9f7742fb9edadee5d SHA512 82baa150fbc7fbc4659b4395f6329daffc1fcfbf773112c05ba114316468e46fb0757f607a15c69ad94c5d9e0dfcfa6fed294debb70fd93063458345e7f295e4
EBUILD python-box-7.3.0.ebuild 1121 BLAKE2B 1732e445b76fb23aa9a1b022385d4d6088d1603c6015fadba226d62f718016b93f755aea127edfdf44d34867cdf05febea9dacb537baf810bc6c87512a4eea43 SHA512 12afcd3bcde9fa28efd1c83f27c1f79b463287c997e8f3db49c478ae3b795dd773162f8c779a301f385e7782deb2546153428bdf45db26e45af1dc5acb765a26
EBUILD python-box-7.3.1.ebuild 1122 BLAKE2B 30ec60f8faa9fb5e82f96f1312bfed1153a4048031a5a6f4e8263cbdf7db8a1f523e8a10d615880e09310c56fb9ad2c8676518f87460aec7236b69e010e46b1e SHA512 083089050d407ca925d3145fd6759ab5e52ab308b7fc25c913aa779b3be050a5a3250fd5f6528263be3c08169e5344e491934eaeddaa2a9dffc23ef39579e483
+EBUILD python-box-7.3.2.ebuild 1122 BLAKE2B 30ec60f8faa9fb5e82f96f1312bfed1153a4048031a5a6f4e8263cbdf7db8a1f523e8a10d615880e09310c56fb9ad2c8676518f87460aec7236b69e010e46b1e SHA512 083089050d407ca925d3145fd6759ab5e52ab308b7fc25c913aa779b3be050a5a3250fd5f6528263be3c08169e5344e491934eaeddaa2a9dffc23ef39579e483
MISC metadata.xml 455 BLAKE2B c87617c0445d56b0b2615ee0727bd18202ff2aacab347e0ddd6e26c2c4a7ea2ec484a01227c7a5a7deec870aae3475422ab4940b15b08401209936d004866c26 SHA512 3d4f528845543f82e21bd97cd4eeea8e52da76634832640a430fe1764f56442a9e909cf14a0426eb64ac64c77a93d619c03731678d0beeb758720261a374b45d
diff --git a/dev-python/python-box/python-box-7.3.2.ebuild b/dev-python/python-box/python-box-7.3.2.ebuild
new file mode 100644
index 000000000000..fd6da46c3478
--- /dev/null
+++ b/dev-python/python-box/python-box-7.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=Box-${PV}
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="
+ https://github.com/cdgriffith/Box/
+ https://pypi.org/project/python-box/
+"
+SRC_URI="
+ https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+native-extensions"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use native-extensions; then
+ # a cheap hack, extensions are auto-disabled if Cython.Build
+ # is not importable
+ > Cython.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf box || die
+ epytest
+}