summaryrefslogtreecommitdiff
path: root/dev-python/python-bugzilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/python-bugzilla
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest2
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild (renamed from dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild)15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index d31caba9c7f3..532041590dd9 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1,3 +1,3 @@
DIST python-bugzilla-3.2.0.tar.gz 114279 BLAKE2B 4d2d7bfaab08dfeb4334462334f23f952b43255e656b0e39eff29bfc206529062c86c79b8c83110fbc5c3970bba40663318b65e208c1b10fb04ab6fb474eeb95 SHA512 215945a0ffd637be5567839303a738a0eef74427838bf0074a5f0ab6022306f47fc0dd5c43a3513b627fb458711f38046321ee9c2c3d43b61ffc577d6dd12375
-EBUILD python-bugzilla-3.2.0.ebuild 668 BLAKE2B d06595c1b9a885fb73e7f7a884beb20b05110f601a8581270128169f87437cfec587a95623e529cc8a42606ea237c64551b2b2271f5741093fc6e8dc7059fb8c SHA512 6f68cf94e384c4b10bd94a437c988e230a3c66a81dc603fc3e318ec9b1f986118fb90a32e3ad1f3e73c6f9877a229efa4584d47f4ed4a8942d2acba976b83be5
+EBUILD python-bugzilla-3.2.0-r1.ebuild 750 BLAKE2B bf334727b8cea37208f2245dba5c8935e0989d78dd6ec3f2955cc7c08246c4bbc463b4121a7a7e7e5330265ccbb606132f2754b392ed166498c58f99a9fcec7f SHA512 539c5c5bac312d4c278a9b6525499caf4c32ffdc366d3af008561e12c29093114a1d8807dcb38e16d6b01ec4d6cb4964a46da81d5a72bafb30bc2e54067ca631
MISC metadata.xml 662 BLAKE2B ef0a5692d9d4f3ca0f474eb012ef97cccba5fa9c8737ac85852d9bb3214160d69fc95eca8239de8d08bf6ea04b5004097ce6b192c2276bc574f441766042c7b3 SHA512 e4ce0016e9ab606c8233759992ea2daa8b20df9b60f129c0b3e210536f0697b46469828de321fa7a09e56889747da67cb38242b739aed227d4a60657207e7f8b
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
index 462b475163cb..a54bcff15482 100644
--- a/dev-python/python-bugzilla/python-bugzilla-3.2.0.ebuild
+++ b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
@@ -3,11 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
-HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+HOMEPAGE="
+ https://github.com/python-bugzilla/python-bugzilla/
+ https://pypi.org/project/python-bugzilla/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
@@ -19,8 +24,10 @@ RDEPEND="
dev-python/python-magic[${PYTHON_USEDEP}]
sys-apps/file[python,${PYTHON_USEDEP}]
)
- dev-python/requests[${PYTHON_USEDEP}]"
+ dev-python/requests[${PYTHON_USEDEP}]
+"
BDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]"
+ dev-python/docutils[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest