summaryrefslogtreecommitdiff
path: root/dev-python/python-catcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-catcher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-catcher')
-rw-r--r--dev-python/python-catcher/Manifest3
-rw-r--r--dev-python/python-catcher/metadata.xml11
-rw-r--r--dev-python/python-catcher/python-catcher-0.1.7.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-catcher/Manifest b/dev-python/python-catcher/Manifest
new file mode 100644
index 000000000000..6dfd51034dc3
--- /dev/null
+++ b/dev-python/python-catcher/Manifest
@@ -0,0 +1,3 @@
+DIST python-catcher-0.1.7.tar.gz 3699 BLAKE2B 20d944f8a87a46423db6981e19ab68eb8abcc87d61d57a9a64332177d3c6b9fa13790a2485084d0754f875611ab57e03704eeeadd9a57637e0bd936e9a8e7ea2 SHA512 118bc19a7c7072cbf95d25810f95753aa894619c5a92b32f56e02a752e48c1b6ccbedab7d538184ec6dc30061826a7924fb0a4644e5afa26dedff9b9cd710353
+EBUILD python-catcher-0.1.7.ebuild 596 BLAKE2B 15e76a97a6a55bcf90585fec02160bfc80cb32a4e18d13a00df62b80b892858594949cb8917a6b6b29b48cabeaf9d760800982d908ac4c22bc5229b00c0d8703 SHA512 3efefc90312dc63dcfb1d19d61c93817d80f2cfbb1d170acabe99b53bf74d023be81ac50dddb1e522064c5815480d1dc3dcd0e706f1af41ca1738e625170a816
+MISC metadata.xml 327 BLAKE2B 5aafd5107217b394f3a7a45b9cda7285e7319d123ef2cde8f26f0a57dd1158aa1b0cdb6a559237d91e50f577cea972708acf2d9e6fd70cd1f0b29a686724b0e0 SHA512 c2c87719253cef67a0f872192250327649fc7db3417384fe4c96343025656455613b0f6ab02521c6249e68882dcaee03257b36a775acc6dba028ce6a11776c53
diff --git a/dev-python/python-catcher/metadata.xml b/dev-python/python-catcher/metadata.xml
new file mode 100644
index 000000000000..0b5922bf69ed
--- /dev/null
+++ b/dev-python/python-catcher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-catcher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-catcher/python-catcher-0.1.7.ebuild b/dev-python/python-catcher/python-catcher-0.1.7.ebuild
new file mode 100644
index 000000000000..24f1f8513dd7
--- /dev/null
+++ b/dev-python/python-catcher/python-catcher-0.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful stack traces for Python"
+HOMEPAGE="https://pypi.org/project/python-catcher/ http://ajenti.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ cd catcher || die
+ "${PYTHON}" -m unittest || die
+}