summaryrefslogtreecommitdiff
path: root/dev-python/python-cjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-cjson
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-cjson')
-rw-r--r--dev-python/python-cjson/Manifest4
-rw-r--r--dev-python/python-cjson/metadata.xml28
-rw-r--r--dev-python/python-cjson/python-cjson-1.1.0.ebuild18
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-cjson/Manifest b/dev-python/python-cjson/Manifest
new file mode 100644
index 000000000000..98995a2988c9
--- /dev/null
+++ b/dev-python/python-cjson/Manifest
@@ -0,0 +1,4 @@
+DIST python-cjson-1.1.0.tar.gz 12298 SHA256 a01fabb7593728c3d851e1cd9a3efbd18f72650a31a5aa8a74018640da3de8b3 SHA512 039e5f724c3a49d0043f788b0634c4191a6ae5abaa012d8491622e5a9ac22ecc5a342a0243f70b0ac02c8640243aaf8b0cf20a0ab12ee4866d9af966d73c1706 WHIRLPOOL 509817683798ef7e9dd7a22c13bff52ce5eb48cdf4aed996603b89fe8d8270e24e90f240adcd14efd1d5326c45edb4f440269e32b7bcb445409a83d44baf067f
+EBUILD python-cjson-1.1.0.ebuild 367 SHA256 b6911cb3217cb8af2c7d93521d04c5ce0f45c9d509d6f52cb5dcd637e7c91596 SHA512 d7eaa436a7c7354e46edb0d7f75f512831ef90b21a4be1f279f56a18022825203b20767d3e069de93ceb794b482272731b321e69ce6084ebe92a256f210d0ec0 WHIRLPOOL 983b2f61afecfdbe585266e75db5cf068b98d94a7d63be6bb2567024a9ae9d67c51e3e0fa719a4e1f87f28809b7c8b5f5d9635c1dac41d5f4eacf43188d2b63f
+MISC ChangeLog 832 SHA256 b069c3aa6d76adc3183b51ea72efe186d2bf4eb7b438b253f76bd8b37e8e07a2 SHA512 70ac986bea72f2c2197b010531cab7171ef90ceaff6a0293c67c20e2534e3f8814c217285268b399ef54c962d483bd0dd12d54dc3b54b6da4a47da45639a3b23 WHIRLPOOL 75ed8086b8110866ac6565cb969cb378a3002ae0bb2dc15908a2223a96cc6f497d548d1c2c744fd364c5d162e686de575f866b2cf6219ca5bdfe43ac08bd3620
+MISC metadata.xml 1135 SHA256 7ed7e38b927405d8d80da4b4ff0e113dd2a9f7b30a9096b80daa1c26e58c6fd5 SHA512 3375f2d4c74b6e111b9e2b9eb9cd23a6660313e05d82b46c05349c517f78dd2ff0f057aa305601b4e0a22ec7db36754fa23108c4442f883824f67a6b6220aa1c WHIRLPOOL d56752147c1230ce973e3a327d0d3d3bd32ff908e081439c4bf05c347e90e7cde566a41b8c8fd0f07aa5a72db4629fd98de179cca896007f231afaafee7944dc
diff --git a/dev-python/python-cjson/metadata.xml b/dev-python/python-cjson/metadata.xml
new file mode 100644
index 000000000000..ff94a57eb230
--- /dev/null
+++ b/dev-python/python-cjson/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This module implements a very fast JSON encoder/decoder for Python.
+
+ JSON stands for JavaScript Object Notation and is a text based
+ lightweight data exchange format which is easy for humans to
+ read/write and for machines to parse/generate. JSON is completely
+ language independent and has multiple implementations in most of
+ the programming languages, making it ideal for data exchange and
+ storage.
+
+ The module is written in C and it is up to 250 times faster when
+ compared to the other python JSON implementations which are written
+ directly in python. This speed gain varies with the complexity of
+ the data and the operation and is the the range of 10-200 times for
+ encoding operations and in the range of 100-250 times for decoding
+ operations.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-cjson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cjson/python-cjson-1.1.0.ebuild b/dev-python/python-cjson/python-cjson-1.1.0.ebuild
new file mode 100644
index 000000000000..f284f1fb32b1
--- /dev/null
+++ b/dev-python/python-cjson/python-cjson-1.1.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast JSON encoder/decoder for Python"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"