summaryrefslogtreecommitdiff
path: root/dev-python/python-cluster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-cluster
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-cluster')
-rw-r--r--dev-python/python-cluster/Manifest3
-rw-r--r--dev-python/python-cluster/metadata.xml12
-rw-r--r--dev-python/python-cluster/python-cluster-1.2.2.ebuild23
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-cluster/Manifest b/dev-python/python-cluster/Manifest
new file mode 100644
index 000000000000..6f8470d0e507
--- /dev/null
+++ b/dev-python/python-cluster/Manifest
@@ -0,0 +1,3 @@
+DIST cluster-1.2.2.tar.gz 44074 BLAKE2B b9a986d326e34d88f193d0bf7ceab404aa17aa8864a8cefa201f47ff0a4372d6a2103e05424f5bc0623cbec3f08beefe2d216c6638969bc85f1cb2432bd5665e SHA512 02600fa1fccdb07251bea83ab81908c22968fcfd4d6ccf382a75ab43117ee8ecc4385f7666f272d1e6cfc0634f7e15778635b50fde572773e564604c981e75cf
+EBUILD python-cluster-1.2.2.ebuild 563 BLAKE2B 243419258179016e8e2ab2ebb2371cb8f76a6791aad1aebb5404f41e1dcda10128afb5f5b5003a1abd75735eee358ca9331a4d03710236c11a20777cf3783506 SHA512 70c6374abcef0a787e9a880a63a59fb4b5f7d7bebc2a23c404c2db187be0c327c74d0ab251c44c1b07e6fee4c9dbe080eabd77ff2651bc441b287a766ad741ff
+MISC metadata.xml 383 BLAKE2B 7600b6607ec5a4890a61f6c72a110de4e0ca3d2138f0358c8d53a63ee36648f16af64df0117825961b2b1b228684589c03759594dc763ae98c775ca4277ec6b7 SHA512 35d45b3af02e3f3c1466d9b915bb8bbfe719105ce91ccf4cd3604c3aa6178228c648316ab2c4f17a113fcf50ed9d1eb94187bf8fced7df1f9f82fb5eaffff652
diff --git a/dev-python/python-cluster/metadata.xml b/dev-python/python-cluster/metadata.xml
new file mode 100644
index 000000000000..070c122ee7a6
--- /dev/null
+++ b/dev-python/python-cluster/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">cluster</remote-id>
+ <remote-id type="github">exhuma/python-cluster</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cluster/python-cluster-1.2.2.ebuild b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
new file mode 100644
index 000000000000..77c50fcac203
--- /dev/null
+++ b/dev-python/python-cluster/python-cluster-1.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Allows grouping a list of arbitrary objects into related groups (clusters)"
+HOMEPAGE="https://github.com/exhuma/python-cluster"
+SRC_URI="mirror://pypi/c/cluster/cluster-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/cluster-${PV}"
+
+python_test() {
+ "${PYTHON}" test.py || die "Testing failed with ${EPYTHON}"
+}