summaryrefslogtreecommitdiff
path: root/dev-python/python-consul/python-consul-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/python-consul/python-consul-1.1.0.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/python-consul/python-consul-1.1.0.ebuild')
-rw-r--r--dev-python/python-consul/python-consul-1.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-consul/python-consul-1.1.0.ebuild b/dev-python/python-consul/python-consul-1.1.0.ebuild
new file mode 100644
index 000000000000..414d22a70c4d
--- /dev/null
+++ b/dev-python/python-consul/python-consul-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Consul"
+HOMEPAGE="https://github.com/cablehead/python-consul/"
+SRC_URI="https://github.com/cablehead/python-consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/treq-16[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
+
+# needs pytest-twisted
+RESTRICT="test"
+
+python_test() {
+ py.test -v || die
+}