summaryrefslogtreecommitdiff
path: root/dev-python/python-ctags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-ctags
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-ctags')
-rw-r--r--dev-python/python-ctags/Manifest5
-rw-r--r--dev-python/python-ctags/metadata.xml13
-rw-r--r--dev-python/python-ctags/python-ctags-1.2.3.ebuild26
-rw-r--r--dev-python/python-ctags/python-ctags-1.2.4.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/python-ctags/Manifest b/dev-python/python-ctags/Manifest
new file mode 100644
index 000000000000..1f392e8aaf82
--- /dev/null
+++ b/dev-python/python-ctags/Manifest
@@ -0,0 +1,5 @@
+DIST python-ctags3-1.2.3.tar.gz 45646 BLAKE2B 3e8d2044a8c06f903efc02d4fa62a0dc3446426ce716a694b8b3daeba92aec56773f0c02a0a360d15a475b4cac32686f34997b98302198c667137b3c1b093f28 SHA512 3bbe730e75a5ae36208113c6e2c43894942002ee37ed700990416fe54d5644b2d2be795935d1392191aae11797ec613ca143343a287596a0a327027c2f170525
+DIST python-ctags3-1.2.4.tar.gz 47774 BLAKE2B 4b1844a6a0d6d89e014206b728e1f1d8b964db2b85afe599cfc254b68f663052d7d1169c257378243e22929297bd254e23ce4c21e1ea1c9a60d7007727c322bf SHA512 db6be08164da71b17de1a7fa46aaa60a5b83784f18ca4e2314e3b9954abe8996d5e07ed98aa024f70899fe87cf53d37671c9f42e567766b4a8af0f728df2bcfb
+EBUILD python-ctags-1.2.3.ebuild 560 BLAKE2B 7f273f6a33998af09ff5539a1e8fcf36df6370df66f561622a4f192be5368e476d9ea0511440e319df7ab288d400dc242d2759e01d7663f32de5977b0a569029 SHA512 a079511d8c81d637bf8b289d31b1fa367cc8659d3eeeda3a2a7f7e70452c846ace9053d1e99250936cfed19668543b77b5799d2fdf238ecdb0a4ef48cc0338cf
+EBUILD python-ctags-1.2.4.ebuild 573 BLAKE2B 689ce02e21ed9d40b8d2ab07d83b9a62ae061f40f2fc83056588fe79d18deda60ecfff9c9fa71a8055ac3752413a9ba3d39bd135c0849a6aeb437d6a2f05094f SHA512 db31dfa573e1ce74f7ec8ab11cbb8a87d8c465347a4f15d6b5ec3386332f9b72941deb089785dc8e82c6e00d4f3f91db4724d9787dc3e56c73718dee30db0cf7
+MISC metadata.xml 454 BLAKE2B 910f1b1ed0136361ce7aea161214ad0bcdefcb23d7244319cdcfb0bc2614236e5fee7a3c6fedebe12a37196e9be59e9d9835edbdc4441357dfaefef71abb0cd1 SHA512 f1b9a8992b0714cb96333c63cd4447915c387ed2e7e5367f9a131a3b1dd18592646915f72235f9f7cf780724d73da3da19a61f849a6dbd6c75c4e0329296e571
diff --git a/dev-python/python-ctags/metadata.xml b/dev-python/python-ctags/metadata.xml
new file mode 100644
index 000000000000..7e80c76c504e
--- /dev/null
+++ b/dev-python/python-ctags/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-ctags3</remote-id>
+ <remote-id type="github">jonashaag/python-ctags3</remote-id>
+ <bugs-to>https://github.com/jonashaag/python-ctags/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ctags/python-ctags-1.2.3.ebuild b/dev-python/python-ctags/python-ctags-1.2.3.ebuild
new file mode 100644
index 000000000000..d4796aaae819
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-ctags/python-ctags-1.2.4.ebuild b/dev-python/python-ctags/python-ctags-1.2.4.ebuild
new file mode 100644
index 000000000000..f225cc435abd
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ esetup.py test
+}