summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-daemon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest5
-rw-r--r--dev-python/python-daemon/metadata.xml11
-rw-r--r--dev-python/python-daemon/python-daemon-1.6-r1.ebuild27
-rw-r--r--dev-python/python-daemon/python-daemon-2.1.1.ebuild33
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
new file mode 100644
index 000000000000..d4be79bc0701
--- /dev/null
+++ b/dev-python/python-daemon/Manifest
@@ -0,0 +1,5 @@
+DIST python-daemon-1.6.tar.gz 41564 BLAKE2B 6ed3dcced0deef859efc733be38d807726ad89c405a2b83bbc05d0e22f8bba64521a82f1127d28b6f69c6553c375f3607d1904e5b6ff190741b0b3c399054953 SHA512 ff9480844d8f57a09f27067aaa78669c167f66b2cc05f9b3baa660bc0aa21228d4894eeaeb3440611c1e0f0d5633b1c60eac60893da4a86d1db4b94d99961299
+DIST python-daemon-2.1.1.tar.gz 74276 BLAKE2B c2ca4d1680555a559009224391151cdffbaf49ee03c0a2985184b336a3d1a8c8372423b3b527199daa5f38a29d52fc879f18a719531afeb18642f7d6cb59df51 SHA512 e2abb9fafea32fe5bc7d239387e3c22aa99f63df31cc4f57908ffdb5dc7f2768358df6ba5f3e827b4f83163628649f58a973b548066e8c79ab3c6c6ce09d8007
+EBUILD python-daemon-1.6-r1.ebuild 622 BLAKE2B c4c0a79d1c7a37bf356da9d1edcab78a8005b2fcf34b126562c4fab98ccc231407a653c01a45e593e17f5172dfe19e3b37af0bc3e7bb98873f85c1fb46a41771 SHA512 4651fa6553e2945f99968de7357180f9fa59fb577afcfc1f1d84b4c573fe050f4ec6d377d7a0036aa1b55ea17dac2436a2184c3b2c0edd8d6c30e559a55045e8
+EBUILD python-daemon-2.1.1.ebuild 824 BLAKE2B dc4a8c6d794c92e67dd73f2a83388a1488f0799aae9e62f7fcbbfbaa9cc2115b0ecfa447f355748965a8751a564583290f614ddef29a6cf1ed6cfdecf5928e02 SHA512 39839bf51a3449d34bd38609284e0500d360f73f1eb1446a29ab39e5d04ea233cce126645738068d9206d82dc4b3b23174683062d23bb15110ae54c060c04178
+MISC metadata.xml 316 BLAKE2B 413934d7b67818ac0d3ddb8c1e5040de2f3008a2e1c01efff6afa4c0aeb6bb849391bdb8730e14091c3efffa47566b831d44cd7728cc9496c6e3bbc7a6c56d97 SHA512 b3b79f6094ec59bc09c2a14e3752edc0722c0e50c9559ac59e6c1355577c1f36ff98ccf6af969d0624b1e6b8b907a7886f6daafb6c0d789a403ec402083b06a4
diff --git a/dev-python/python-daemon/metadata.xml b/dev-python/python-daemon/metadata.xml
new file mode 100644
index 000000000000..19019cc44c02
--- /dev/null
+++ b/dev-python/python-daemon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-daemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-daemon/python-daemon-1.6-r1.ebuild b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
new file mode 100644
index 000000000000..ab45831357e3
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/minimock[${PYTHON_USEDEP}] )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-daemon/python-daemon-2.1.1.ebuild b/dev-python/python-daemon/python-daemon-2.1.1.ebuild
new file mode 100644
index 000000000000..45620ded0aec
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/unittest2-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}