summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 09:49:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 09:49:59 +0100
commitdd4e83dc96a7c8d12e5ecdfde7fb07196ded331b (patch)
tree31769a55af540c0f76f798bf230075a7e9dd842c /dev-python/python-daemon
parent850d399c4f1568d3c6d013d7f4e2e371c0118bd6 (diff)
gentoo auto-resync : 23:10:2022 - 09:49:59
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index e4c0af2e0f4d..4b361a00ce6f 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,5 @@
DIST python-daemon-2.3.1.tar.gz 82856 BLAKE2B d1ede5fde50f179b0bf3e3ed89bd988469bae1f57667ab601d44452706a84264f55fc9beb89226e5fb1bb6d92f88fc2a5c2497628de16990407a0e01cfbacd84 SHA512 128fd8ac125eac613936668bb555635c8cec576d5c23513210f0956983c70720dd93906adeee581b192b57480a3df93dc1e08f6f7b62e38b2404fa00aba4805a
+DIST python-daemon-2.3.2.tar.gz 83127 BLAKE2B bce00867850e8451bcaf5a51864bdd751fa3b5e7be8ae1d36d724a915680713fc66c0fc6c8499bce03e0eb86465f5806fb8645376e600b8eac579fee3c24a087 SHA512 d9f6e6c376a496fae96bd9efed0a56d00a137617a3d1d5ef74802ef176bc813bb1d49bbb9164cdbec03213529f944b32b257bcc64283abfa4a3522ff00826bfd
EBUILD python-daemon-2.3.1.ebuild 784 BLAKE2B 2f2460fe82bfb8c2b864308e4ed3c680a2571d9a7281ff2e76db414e327031e2b474d654e8ac017242dc52d4988ab6c8c6bb653ddc342632e4ca7d616d072ad8 SHA512 5c55229a3cccf2b22d2f0c21e3d87b4464ee9f2edb5b381ddd7242646759bab231ec1e93d07e068acb234e69891e2db112b98372e7a1dbc351d0045ed3de0a60
+EBUILD python-daemon-2.3.2.ebuild 788 BLAKE2B b03c2ecca82305d79a2c7bf3f620e90073d1087706ae25079c656c6f79f694d6e32eb7eeff43181a7f98522412523f55c4132129c112081b594cd1889a15fb96 SHA512 496e3375f72ab1d8794f1580924aeb52c55250e184766bce30bc6f6c3f6fdaa795c2f9f7b40d78d2ca1c019a946e402f0ae3128335bfbcb9c604925a840fa874
MISC metadata.xml 341 BLAKE2B 62d37c28a9bf9e9fc6e2dd9fc5295558eb395dac54a45e548ec7d6738fdebe42053cd2f85b160135fe8fe5828eb065bf7d95b17f3c76697ab6ca2f0e664ffb8b SHA512 83badd112e5e5ed2584cd883abc20b43a18585e7c1d006c4d4861f555e633225f251d7c5b05e2e8f94f74107e32a5eeffcdd3f1265feb463f7c521c7c7141752
diff --git a/dev-python/python-daemon/python-daemon-2.3.2.ebuild b/dev-python/python-daemon/python-daemon-2.3.2.ebuild
new file mode 100644
index 000000000000..559c6c2abcbc
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="
+ https://pagure.io/python-daemon/
+ https://pypi.org/project/python-daemon/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest