summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/python-daemon
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest3
-rw-r--r--dev-python/python-daemon/files/python-daemon-2.3.0-fix-py3.10.patch28
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild6
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index ebce4716cb4d..5dcc3e169c12 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,4 @@
+AUX python-daemon-2.3.0-fix-py3.10.patch 1137 BLAKE2B 6731a8f43214d3a69bd577b1cfbe1252c21d0f76377026a73a09edcf9f8a99f88e104214ebece37a8a658c458fab0c4970796f46a8b976218062a4b5ab4e4e0f SHA512 5012ad1c3a4b2e88c16e7e3bb64761e9b99a8233e25808aed9e9ddaeaeb9c47b8b3b0884ca927f9d7c36239b84c932f96ef4d84e26cc005f25bc222332f1c4c6
DIST python-daemon-2.3.0.tar.gz 82831 BLAKE2B 6e7fa082a513827283f46044347dfd445633db0d1781a33aa1bc5b14c340da784310ae6bd07d6cf3673cd05cb14a9d090ab51857d26cca52d09bc8c3b195360f SHA512 30bb70821aae720d09032c8c666524fa9a1a486314ffff73eb161231a1f2b954914295b4ad41f9c8529bc045fb6d0f89256bc59f8979a4f8a6698e9bd4d7441a
-EBUILD python-daemon-2.3.0-r1.ebuild 865 BLAKE2B 21c7f9270f5121e2bf5d0893b78225bc6d2fafa90c9fca7b7ca6d7df6dd497b061871b4b66ef97a13719008869329853aa3ba59836fa83ff9e3058e0dd0c78a7 SHA512 c23e13f933c6136853e758a19a68d0a22e113148e1a368b9735c2bc409a88843328ddc7d644f9a19f954878af79c3fac940951101e2e28a2b864f99aa15b6381
+EBUILD python-daemon-2.3.0-r1.ebuild 916 BLAKE2B 20e2b44d23b276872a93fea5cfb193ba41ab3f4421c22e9e6be82277e3256e5996155339558b77cb4ddbe2a09d8b8fd62bf3be32dcdf3b5e9a20df374ccccfc7 SHA512 5f2cf9dfded0645053b1a8c68c5264a70963a3248918cae8a382d051097c46fc328235bceaedc9573d7bee02ef04b3d6d1bcd93f836ef6839b6e1b4b931806b8
MISC metadata.xml 341 BLAKE2B 62d37c28a9bf9e9fc6e2dd9fc5295558eb395dac54a45e548ec7d6738fdebe42053cd2f85b160135fe8fe5828eb065bf7d95b17f3c76697ab6ca2f0e664ffb8b SHA512 83badd112e5e5ed2584cd883abc20b43a18585e7c1d006c4d4861f555e633225f251d7c5b05e2e8f94f74107e32a5eeffcdd3f1265feb463f7c521c7c7141752
diff --git a/dev-python/python-daemon/files/python-daemon-2.3.0-fix-py3.10.patch b/dev-python/python-daemon/files/python-daemon-2.3.0-fix-py3.10.patch
new file mode 100644
index 000000000000..4fd082dc8f77
--- /dev/null
+++ b/dev-python/python-daemon/files/python-daemon-2.3.0-fix-py3.10.patch
@@ -0,0 +1,28 @@
+https://pagure.io/python-daemon/c/0c67a3c6407fbf4483ccfc94a7a0d78cf3379296
+
+From: Miro HronĨok <miro@hroncok.cz>
+Date: Sep 29 2021 10:05:27 +0000
+Subject: Remove incorrect double-patch of objects in test cases.
+
+The specific test cases relying on the patches, already are decorated
+to patch the specific attributes needed. We don't need a general patch
+of the attributes in the test case setup.
+
+Signed-off-by: Ben Finney <ben+python@benfinney.id.au>
+
+--- a/test/test_pidfile.py
++++ b/test/test_pidfile.py
+@@ -367,12 +367,6 @@ class TimeoutPIDLockFile_TestCase(scaffold.TestCase):
+ pidlockfile_scenarios = make_pidlockfile_scenarios()
+ self.pidlockfile_scenario = pidlockfile_scenarios['simple']
+
+- for func_name in ['__init__', 'acquire']:
+- func_patcher = unittest.mock.patch.object(
+- lockfile.pidlockfile.PIDLockFile, func_name)
+- func_patcher.start()
+- self.addCleanup(func_patcher.stop)
+-
+ self.scenario = {
+ 'pidfile_path': self.pidlockfile_scenario['pidfile_path'],
+ 'acquire_timeout': self.getUniqueInteger(),
+
diff --git a/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
index ebd89363d0b2..6cb93f1a8363 100644
--- a/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
+++ b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -29,6 +29,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
distutils_enable_tests unittest
src_prepare() {