summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/python-debian
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.40.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 5d15b87e8194..8327f7ab65a2 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,4 +1,6 @@
AUX 0.1.39-disable-apt-pkg.patch 6815 BLAKE2B 443dfc1c0c60d47709f31f1d3f0196c703490a9491e8de61ea9a093a80e5d87fdf17e1b1ebd5b885a1e2c0104c243aef2dee4a8f1902b9b5f747ec1b797c93a9 SHA512 ffb0659feaaa1538bc7a40b896e6bfc53f51032aadf0c0642a3609d10a13a043c2bbea97e43fddd315fe5aa174a94c9fb3fbb9832bfebdf2acebd7a30cea3717
DIST python-debian_0.1.39.tar.xz 319020 BLAKE2B de38ddc6e4878404f9685a264e1198e513cb57f7bfea064e4512ee00049d007b6007ee7fea42e18bd2f12dc8132582fbea2235694b5f908c9ae5cbc830cfe98a SHA512 de29ef224a17b149dde8cf6bb4b9fe77aa1fdfc040463163fb97f7e4ed283f16af43422e26c352183fd74e9e0ff6b41a91ee18c63b5534d5c9de2ef663c8f4df
+DIST python-debian_0.1.40.tar.xz 319952 BLAKE2B 4d5c2d3202ef09fc8eba4e0c4f9a5861d0662f288768cb9026e1ab43309a57fb21c0b8e87734c9310f39646e071947b31b17bd48b71510e7d783af9f337c3ed1 SHA512 73ed735a3c7bb43208aa26ea9fd64fc658e111dc201ae8c1947a4e5835ebd675e37b78d2895d72bd5ed2b6afa491e77b50bd5f10d62ea8299fbdda6c0b9e5095
EBUILD python-debian-0.1.39.ebuild 766 BLAKE2B 8c0fe936e3786037eccfcf50080d232fafb2141800ed726e05ff52f09279ed653b723702b044a57d7f1a49462c0b81e81bd0260cf7155fd18d0fbbd035a4ccd5 SHA512 b6e3e18338d5f5891cfe104654932d551aec3fd1207d776e329562d18068b3ca72f1f9c239c82efbcd0e6769f7cab8b1adf5ebf74889926835d30c4e07b17f7f
+EBUILD python-debian-0.1.40.ebuild 769 BLAKE2B 2f0c3a60abc67fd6a30f9431009d68dcbda49cce0d435af31fddd1c57f89bb2dec3bfbffbaf059c19421a2806a91586e58087b37a7315e66e2097c12b43d8ca6 SHA512 6ee0e983933495de3d8f413229c21f7b48b6188a4d7c94cf02b48d0c74ee34bf55b0efadae4f7225dd55c8836df1a9bb7865a94414e1908bdf035ceb4baf4472
MISC metadata.xml 447 BLAKE2B 3a50201209da0fe9153963a3c84fbfcd72eb2a9065c6ef2dc6d21436d12269d6188e7b5c3bf88688e91bdde0e8f33a1adf9d11e084cca4ef796435655ec32765 SHA512 54c833fe01cfe54156de60c39d5cab5f9324074ddb2efd0c8294cc55d3ef599c0c65e911855c93bbb4f42cdec489dc5b337b0a0a53113816110321ea291538e1
diff --git a/dev-python/python-debian/python-debian-0.1.40.ebuild b/dev-python/python-debian/python-debian-0.1.40.ebuild
new file mode 100644
index 000000000000..dfab437931aa
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.40.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2011-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( app-arch/dpkg )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=( "${FILESDIR}/0.1.39-disable-apt-pkg.patch" )
+
+python_compile_all() {
+ ${EPYTHON} lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}