summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
commit9d4810f84de876ec9d0ae03d0d44224500b41188 (patch)
tree1ca0866afdc949e405d20635d3d7f2115abb9ace /dev-python/python-debian
parent075fd1f8cabc5879c6eb42127fb84c3058677fde (diff)
gentoo auto-resync : 19:05:2024 - 00:01:59
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.49.ebuild9
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 172d0968ae36..e76e1e398d17 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,3 +1,3 @@
DIST python-debian_0.1.49.tar.xz 191388 BLAKE2B 590e6f7877684caaa5a74f06d335bcf7808960968209cf18bb2cec7e81f33a3b0ff458bbe30264ae5fc015de9357dddb1522b5fd93bf33d0a7fabef1b7dd98f9 SHA512 201ceecdd8c1d3dc0cca0f661407bcfb825a1cba07c528858cc1123ab16afe0df50e338c8cd82ea24230812a9cc136220bd4f0dccbac19ad53efe48eaa25cf6f
-EBUILD python-debian-0.1.49.ebuild 984 BLAKE2B 34007b063e3954c1191a57d7985362e58f1906527d7bbde39ce95a9422d0107ddde66e83ba209aa7cb305121e98aa0117a4391ef2264b6ebaa46d3a9f4d12525 SHA512 55003b5f1da7440965aadfcd4c68e4f182698e6541e5540eb99405a4a3dda3b5de2d29cdf4eab6f6964b22566ba6c1fc2aa9c36c5985b26e42f5f6207562af7f
+EBUILD python-debian-0.1.49.ebuild 1034 BLAKE2B d1242f63aac6531b6112af697e56037ced54aa4625d7cda87f743a3097bcacf9b5083864228736271149c2cbd3ea9bbed58dc23f461f4a89e24df8d0b7f1da66 SHA512 007d8726fce7a6bda5fe00a3aca554770e318954e54dcda42a1c03e4527a9c29c04c98ef4f0923f2379715de3324438d9e67dd4d9759d9f2d4cf15ae3e77fa0d
MISC metadata.xml 448 BLAKE2B bccb39bdfb24e81bc05028fc92033468f5256be096cb409b4413f69444d59d3d9a3469047337a7fec79ac707ddf4d269b44b20c725f7fc4935bd10335e1f9374 SHA512 8e3fb6ca4bf305e23a51ff56cf84648aad1e96d36aa7a4fb138f7136ea77a6a76a8985557ecb1c9da962479c8c9e36c253655d6e6602c1833f2a2230b44540aa
diff --git a/dev-python/python-debian/python-debian-0.1.49.ebuild b/dev-python/python-debian/python-debian-0.1.49.ebuild
index d99f43c8102f..855bcbe7bcc8 100644
--- a/dev-python/python-debian/python-debian-0.1.49.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.49.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2011-2023 Gentoo Authors
+# Copyright 2011-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -32,10 +32,13 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
+ distutils-r1_python_prepare_all
+
# See debian/rules.
sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
> lib/debian/_version.py || die
- distutils-r1_python_prepare_all
+ # silence false positives
+ rm -rf debian || die
}
python_compile_all() {