summaryrefslogtreecommitdiff
path: root/dev-python/python-djvulibre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-djvulibre
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-djvulibre')
-rw-r--r--dev-python/python-djvulibre/Manifest5
-rw-r--r--dev-python/python-djvulibre/metadata.xml8
-rw-r--r--dev-python/python-djvulibre/python-djvulibre-0.8.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-djvulibre/Manifest b/dev-python/python-djvulibre/Manifest
new file mode 100644
index 000000000000..2022508d0bf0
--- /dev/null
+++ b/dev-python/python-djvulibre/Manifest
@@ -0,0 +1,5 @@
+DIST python-djvulibre-0.8.tar.gz 85436 SHA256 9d6bf3143fa540e8ce330949c9edff7847ad7cd715f7c02e2991212873a5f31b SHA512 c817fc518f398bf16664a5f5dc80e8bd086015c13f82c5265548e5ca5d90f293cb2132961ba8a73cb184bc7883bb5868d2d49ecd950d045d0729f876703e710c WHIRLPOOL c1b23f141ab31eb427aa7b373b55b9886ab2f1189d35837741503e442d7ce80e70550ecfba091052cf5d126b46de8ccf5632205acb8d229993abc75ebdd3c725
+EBUILD python-djvulibre-0.8.ebuild 709 SHA256 7dd2841ab993ad1997907935c8713cef9f64a376dbc9afda9174a6f09aeb4e56 SHA512 a22874c1220ac2888984d08835dc3ca292520013e6cb237be1ce32f58c8fe2e921ba3dc3bd18f5796b64f696c7359ad66d56285ab98d851fa5a3e189b5973566 WHIRLPOOL bc35d196aba84d1008928e5af0923ca96a65dc7c33130ed1d24a1d83850a7fda243a08529e3b00a4f0a2c94d36eef432e3b704fa374eb42997bc0123e55c1ecd
+MISC ChangeLog 2205 SHA256 0f90c3e77c0af06d68bf4812c40c333a0cd5650d2bed5dd42c1f12cf49470f61 SHA512 190c099b7188ed487d7f780a398e5270cd8b489df4237d5984c163a009cf89bb1a5edaa0023ccd6e73a42595afecd34214bfca665bcee472dae81a30174aaf17 WHIRLPOOL c2de11390b234a4927fbaca17719806c49e3f07377e60016c4837531b54165b3ae0404527725b542dcfeceb3b081d0dc4eb4c7e14cb58d5658554fd488fbdf27
+MISC ChangeLog-2015 785 SHA256 68d080a29e239181db00ff62eec3b023f21cd82b6897adc6bbe0f6051a0faf8a SHA512 c31b8d318d28257d0326df710927d25d38b13afea058396bbcd320a162736aebf3365809deea69490ce3016b27ddb66f133cfb9c89e7d08d634c0ff27ca5aad9 WHIRLPOOL 2f74738f3a3faf7acaed5c4efab9ab6152a5034b2d5e40ff299e15a4ffceae8f29e3d050ef84e8081321d4c26fd8580ffc2e64762170c5c32b90eb0fef84bece
+MISC metadata.xml 246 SHA256 82906624d3dafd4a3206a3e8d4851cff673513a5e58e993ad518e786f00ef381 SHA512 6099e01ca48241e19c169add69c7f98fcb503ab4726bc60779c5195c0f3b5f419112a7973eb477cdd3d6a60f34d99d821fa41f17b04f639de5e551e90f5164b6 WHIRLPOOL 6b98bda11f18dc3351443ea9dcd07dde48acd2a23bfed3fe3dfbc0746ef17a2a9c139b0f76ca4c4de905f92ea666a11d50f1d6df3e591ce83b7706d8f90074cb
diff --git a/dev-python/python-djvulibre/metadata.xml b/dev-python/python-djvulibre/metadata.xml
new file mode 100644
index 000000000000..3383b6ee4748
--- /dev/null
+++ b/dev-python/python-djvulibre/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="pypi">python-djvulibre</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
new file mode 100644
index 000000000000..7eeb2b653895
--- /dev/null
+++ b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of Python bindings for the DjVuLibre library"
+HOMEPAGE="http://jwilk.net/software/python-djvulibre"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/djvu"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ ln -s "${S}/tests" "${BUILD_DIR}/tests" || die
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die
+}