summaryrefslogtreecommitdiff
path: root/dev-python/python-djvulibre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-djvulibre
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-djvulibre')
-rw-r--r--dev-python/python-djvulibre/Manifest3
-rw-r--r--dev-python/python-djvulibre/metadata.xml8
-rw-r--r--dev-python/python-djvulibre/python-djvulibre-0.8.ebuild31
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-djvulibre/Manifest b/dev-python/python-djvulibre/Manifest
new file mode 100644
index 000000000000..4aa4e8718856
--- /dev/null
+++ b/dev-python/python-djvulibre/Manifest
@@ -0,0 +1,3 @@
+DIST python-djvulibre-0.8.tar.gz 85436 BLAKE2B fa30c4e78ce41a0f8c3af1580806f82fe856ac7012cb26dd7380158f5a0fb8b78d9f6e0bacbaf146959db7334fca4afec9caa324d8c2d6af697b3e0a171ee1ee SHA512 c817fc518f398bf16664a5f5dc80e8bd086015c13f82c5265548e5ca5d90f293cb2132961ba8a73cb184bc7883bb5868d2d49ecd950d045d0729f876703e710c
+EBUILD python-djvulibre-0.8.ebuild 713 BLAKE2B cfeab901b187a2ac1c72147be2b02bcfc5d813e1448c7361860d343cc35a03484cc912ab6b104081cba7606307a042b761b4fbacdc0917c55378d507ce1a9748 SHA512 6446e5e3a3c970029799562ad5baa2fbd56524115339608b616415619fc980c45e7096ea47fecf09441f99a2563fe848edceff8d31893d2c20750124de945bf4
+MISC metadata.xml 246 BLAKE2B 9254d9230f40389806de235731356f89790a3a7c9bd8c3e78173cea5f21921ec2da32123b44d64e8630c1191d0accc2e922e3cc8b86d7edc4a7f42993d9b97ce SHA512 6099e01ca48241e19c169add69c7f98fcb503ab4726bc60779c5195c0f3b5f419112a7973eb477cdd3d6a60f34d99d821fa41f17b04f639de5e551e90f5164b6
diff --git a/dev-python/python-djvulibre/metadata.xml b/dev-python/python-djvulibre/metadata.xml
new file mode 100644
index 000000000000..3383b6ee4748
--- /dev/null
+++ b/dev-python/python-djvulibre/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="pypi">python-djvulibre</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
new file mode 100644
index 000000000000..9b7b81260c33
--- /dev/null
+++ b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of Python bindings for the DjVuLibre library"
+HOMEPAGE="http://jwilk.net/software/python-djvulibre"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/djvu"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ ln -s "${S}/tests" "${BUILD_DIR}/tests" || die
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die
+}