summaryrefslogtreecommitdiff
path: root/dev-python/python-docs/python-docs-3.3.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-docs/python-docs-3.3.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-docs/python-docs-3.3.5-r1.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.3.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.3.5-r1.ebuild b/dev-python/python-docs/python-docs-3.3.5-r1.ebuild
new file mode 100644
index 000000000000..1a47c21852de
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.3.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.3"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ dohtml -A xml -A inv -r ./
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}