summaryrefslogtreecommitdiff
path: root/dev-python/python-dsv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-dsv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-dsv')
-rw-r--r--dev-python/python-dsv/Manifest4
-rw-r--r--dev-python/python-dsv/metadata.xml11
-rw-r--r--dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-dsv/Manifest b/dev-python/python-dsv/Manifest
new file mode 100644
index 000000000000..a36a1c6629ca
--- /dev/null
+++ b/dev-python/python-dsv/Manifest
@@ -0,0 +1,4 @@
+DIST DSV-1.4.1.tar.gz 14682 BLAKE2B d34b2d72f2efa2d7aa11dd99ce1e891d3663649a47fea1538faa086806bbd1e3ed578143c870b4a76ab7f2ac76f3cb46b50b64d026655a1c643a2081276dbd5a SHA512 c26df1efabff9e70b6dfd17f6ff928f022ad19cfa39af431ef7ac663687e8d80406b0ad471376e238eeb6fcbab31aa2a84eaeae2949173e22316eb92e51f7ada
+DIST python-dsv-1.4.1-gentoo-patchset.tar.bz2 5259 BLAKE2B 3367d27bddcb7274dde2429147495f9c46c40e421034234ddc19ac1bb064d118289249ec575a51057008e0808f4d431c54a6792df60c10408dd55898421f3160 SHA512 c36335e5a6e423c53a9edec9dd795054e77b81a638d774a445bf1b621119c703064892eaff7ec67f85ce7e693af1156c39b3e60faaa5a800c1eca28ea7544f98
+EBUILD python-dsv-1.4.1-r2.ebuild 801 BLAKE2B 25d6a0181db9fece93c63983a745e8da3f99b89fb47320a0ac60865390ab3974c65e073e0b7b02e4dbb4353b85c6374a466750f8bacf3f358e41bb5e94854a4b SHA512 b258980d977cc4aa7892538d7b9cc4d99e60d8be0b863fad0eb313f80482299636e2782bc7178f67a2c127529e15a25c854225af29d4fe81ee0087289f417341
+MISC metadata.xml 501 BLAKE2B 62742bcd65f6d25178f1360ca3f9666292786342fd8eae2ae706bea30a0137b5614ca0c018eebac66352fdc19eca680e01eda34f0abe687ef8b47ca4abab7cff SHA512 e8094c00b37097b8f255a6f2ab3461340fcec715bbe63957369f2ee4c60c4e246ba53f3dcf0edcb248937e70316ef9c4c2ff3c2609c2f79ccdd485ceb54918f1
diff --git a/dev-python/python-dsv/metadata.xml b/dev-python/python-dsv/metadata.xml
new file mode 100644
index 000000000000..0ae34c0a45ea
--- /dev/null
+++ b/dev-python/python-dsv/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>Python module for importing and exporting DSV (delimiter separated values) files.
+DSV is a generalization of CSV (comma separated values) and it is a common file
+format used by many programs to import and export data.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">python-dsv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild b/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..b9159dd4d24f
--- /dev/null
+++ b/dev-python/python-dsv/python-dsv-1.4.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for importing and exporting DSV files"
+HOMEPAGE="http://python-dsv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/DSV-${PV}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/${P}-gentoo-patchset.tar.bz2"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/wxpython:3.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/DSV-${PV}"
+
+PATCHES=(
+ # From Debian
+ "${WORKDIR}/${P}-gentoo-patchset"/${P}-env.patch
+ "${WORKDIR}/${P}-gentoo-patchset"/${P}-unicode.patch
+ "${WORKDIR}/${P}-gentoo-patchset"/${P}-wx-namespace.patch
+ "${WORKDIR}/${P}-gentoo-patchset"/${P}-wxpython30.patch
+)