summaryrefslogtreecommitdiff
path: root/dev-python/python-efl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-efl
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest2
-rw-r--r--dev-python/python-efl/python-efl-1.26.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index 003626c80aac..b0bfc5847103 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,4 +1,6 @@
AUX python-efl-1.25-clang-crosscompile.patch 579 BLAKE2B d308bf06950094a00fbbad24f4813b6dd511122071328f01ab2bd774ba1cd79cca7cddffc8dad4d65c8cc83430f99d59a55dfc2a5d4805a54f62ae0ece880a3f SHA512 3da1b63c7d40dc8027db5bcd6ab165789790e4db8c3ad876d55eda9363557cff8a46858a2ca8c23d1bb8e1e43bb7b057ff596aebe7adb2c40f3bb18b37e71225
DIST python-efl-1.25.0.tar.xz 9543920 BLAKE2B fc2b951ade2fc2b7c32dd78a84800bc9f225499ee9d8431034b378c86e423181d918aba2c4d056974f3aa2df9cfb9c7b3dcf1c366362387048cde182c0b3128a SHA512 23ed29add25cd2639e9eb144f22c5e2809b8634389f7ab5c4b7ebc19302fde4ebb0fe8c41d7b10923e658676c4dfbb8670fda16675682fd376258beecbc3d9c3
+DIST python-efl-1.26.0.tar.xz 9547648 BLAKE2B b6fd9e86695569291b416140c92316aeb4e3bd42d12fc3fd656b86fe7fae364720c8457c53828dc00838a68620fa604426d86c5d4bce02e94eaa82a4fed120ee SHA512 fe552a65d7d4d3e3664310e6bb7189c883c64361a64a2def04e8d14df3e5a03211e2992333f1c05288b96f1d99f20ad4ac848baea91d43db280dad81315e2473
EBUILD python-efl-1.25.0.ebuild 1809 BLAKE2B 93fce1140f0d41d992725805df87be45324b00f673ba54bc629e1bab6f1aa4908a69f8fe1c6464d5805cee55aff3a9bf8dc3d2faaf1f25c2f13aefeddb73c77f SHA512 a1fa37dc4ac7486f952a7c8b23dcd5689b8c3bc58f23eff1b632eb7d4f2fc764f2a5770313e0742353c62c16e9b005014ad56bc52ff62f1da45a3c9a517865ce
+EBUILD python-efl-1.26.0.ebuild 1926 BLAKE2B 7d8ea6e029ffd25379017c6c0a3ed8869cb6c974f49107da755f4fdf505eed94667a9881212bba460e0adc332e36f16806f4ea5bba0d8af62847ab07d7863a1a SHA512 c81d9b53d2233aaa902e9fd40e4f2987e2f31295561fcc5d58d6eeed944629e5a94a4f3780de1d711cd8a8d2f229ffb079bffce84e70974fdec9215ef5874451
MISC metadata.xml 644 BLAKE2B 4e3a5aeefe0fbf3202b78ac6352684f7f39e4d7759354fb2083977508b5e6a96723e8bd9883f3b34369f0bf727074069d8486e8b55d7b6aa35f6b0e69860a46a SHA512 cc205894b237747d702273567fcf32ebb418d7917d14a7c8e0af4ea8d569fc0ad9973a5de1179444bf2ff4680be7e537893b988ece0cfad9cf2157de1237886f
diff --git a/dev-python/python-efl/python-efl-1.26.0.ebuild b/dev-python/python-efl/python-efl-1.26.0.ebuild
new file mode 100644
index 000000000000..58519da4343f
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.26.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://github.com/DaveMDS/python-efl https://docs.enlightenment.org/python-efl/current/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="=dev-libs/efl-$(ver_cut 1-2)*
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )"
+
+PATCHES=( "${FILESDIR}/python-efl-1.25-clang-crosscompile.patch" )
+
+src_prepare() {
+ default
+
+ # Generate our own C files, discard the bundled ones.
+ export ENABLE_CYTHON=1
+
+ # Tries to download a file under /tmp
+ rm tests/ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm tests/ecore/test_10_file_monitor.py || die
+
+ # Needs an active internet connection
+ rm tests/ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
+
+ # Make tests verbose
+ sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
+
+ # Disable any optimization on x86, #704260
+ if use x86; then
+ filter-flags -O?
+ append-cflags -O0
+ fi
+}
+
+python_compile_all() {
+ if use doc ; then
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd tests/ || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ./build/doc/html/. )
+ distutils-r1_python_install_all
+}