summaryrefslogtreecommitdiff
path: root/dev-python/python-efl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
commit522fa4e6f267ba688a264ceec8d6c79663b61219 (patch)
tree67895f3a8243148309fbd841dabba28c37f4ed4a /dev-python/python-efl
parent32c16465e56b0122cf6e5a4625e9c7b56b107b07 (diff)
gentoo auto-resync : 08:10:2023 - 12:03:01
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest4
-rw-r--r--dev-python/python-efl/metadata.xml1
-rw-r--r--dev-python/python-efl/python-efl-1.26.1.ebuild80
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index a54c9dda71a3..8decf503feb3 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,4 +1,6 @@
AUX python-efl-1.25-clang-crosscompile.patch 579 BLAKE2B d308bf06950094a00fbbad24f4813b6dd511122071328f01ab2bd774ba1cd79cca7cddffc8dad4d65c8cc83430f99d59a55dfc2a5d4805a54f62ae0ece880a3f SHA512 3da1b63c7d40dc8027db5bcd6ab165789790e4db8c3ad876d55eda9363557cff8a46858a2ca8c23d1bb8e1e43bb7b057ff596aebe7adb2c40f3bb18b37e71225
DIST python-efl-1.26.0.tar.xz 9547648 BLAKE2B b6fd9e86695569291b416140c92316aeb4e3bd42d12fc3fd656b86fe7fae364720c8457c53828dc00838a68620fa604426d86c5d4bce02e94eaa82a4fed120ee SHA512 fe552a65d7d4d3e3664310e6bb7189c883c64361a64a2def04e8d14df3e5a03211e2992333f1c05288b96f1d99f20ad4ac848baea91d43db280dad81315e2473
+DIST python-efl-1.26.1.tar.xz 9554132 BLAKE2B d08c9c695c3667e0d3b1b45b1c7026f1af6ca1c100235c1a412dfa354e549c45db75442693c1d7a3f68b6c63a47cf6d120fd3071856a6e7c7da51f0ccdb309b0 SHA512 42b7586885d47fc67bf3692e65325e58cb0566fb772b415255b2f63b05adfdcdc44762f532bc951781ece118833486b33dc5a3f0aa10e0a14d5226ca4dc30f9e
EBUILD python-efl-1.26.0.ebuild 1926 BLAKE2B dc7e584b0518dcc6ff66b23c57a0f8b9e0b32206932d41cf4ab6128cb46e8a65b30799dbf6d48baa545e6661e31a9429a8009a3f12319aafc4c57ebbdae42593 SHA512 dd9dd79b6eccf85a16387cd048fccfbb85f02b582f21238d48101edb48f6461bf8a1bc7bf90f003dfd987d39b5b7e2223b40db04423c428c28e76d9f2fc336b4
-MISC metadata.xml 644 BLAKE2B 4e3a5aeefe0fbf3202b78ac6352684f7f39e4d7759354fb2083977508b5e6a96723e8bd9883f3b34369f0bf727074069d8486e8b55d7b6aa35f6b0e69860a46a SHA512 cc205894b237747d702273567fcf32ebb418d7917d14a7c8e0af4ea8d569fc0ad9973a5de1179444bf2ff4680be7e537893b988ece0cfad9cf2157de1237886f
+EBUILD python-efl-1.26.1.ebuild 2041 BLAKE2B f75d5471ad2c2610f59accbcc01c23cc38eaae8d940b7553fccb936e5238f18c4281461cea70462e4ee442319df9d721991fd6cb0ed99ba58ff47310df648a76 SHA512 bd68ad3ab3822f692f2874b07f0fbb57ab406f4e2092c9bd471b95da17af4bd80915903bfa987c2faedc6a2c4e585c9e9adeb161ac9663e637f6f4f8a4e7b5c1
+MISC metadata.xml 702 BLAKE2B 576ad2ee49ac6c671f77b8d5b3eb889fdedccba21a5a248e4be3c9b56130422092407da0d170e16009c34881124f287fba23db863b5c6fcc0d8d2713d1a64b85 SHA512 0ac844b8773881f7993fb550b8b7fe7d3ea815673a68a66e14dd194a576f0c28074cfd54dffc106d744c0aa19141361fe33e376c41ae0e5bf55d2de10013526b
diff --git a/dev-python/python-efl/metadata.xml b/dev-python/python-efl/metadata.xml
index 18081592f958..c88f176c6144 100644
--- a/dev-python/python-efl/metadata.xml
+++ b/dev-python/python-efl/metadata.xml
@@ -15,5 +15,6 @@
</longdescription>
<upstream>
<remote-id type="pypi">python-efl</remote-id>
+ <remote-id type="github">DaveMDS/python-efl</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-efl/python-efl-1.26.1.ebuild b/dev-python/python-efl/python-efl-1.26.1.ebuild
new file mode 100644
index 000000000000..8e4eaeabe130
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.26.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://github.com/DaveMDS/python-efl https://docs.enlightenment.org/python-efl/current/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="=dev-libs/efl-$(ver_cut 1-2)*
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+DEPEND="${RDEPEND}"
+BDEPEND="<dev-python/cython-3.0[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )"
+
+PATCHES=( "${FILESDIR}/python-efl-1.25-clang-crosscompile.patch" )
+
+src_prepare() {
+ default
+
+ # Generate our own C files, discard the bundled ones.
+ export ENABLE_CYTHON=1
+
+ # Tries to download a file under /tmp
+ rm tests/ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm tests/ecore/test_10_file_monitor.py || die
+
+ # Needs an active internet connection
+ rm tests/ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
+
+ # Make tests verbose
+ sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
+
+ # Disable any optimization on x86, #704260
+ if use x86; then
+ filter-flags -O?
+ append-cflags -O0
+ fi
+}
+
+python_compile_all() {
+ if use doc ; then
+ ${EPYTHON} -m sphinx.cmd.build doc "${S}"/build/doc/ || die "Building docs failed with ${EPYTHON}."
+ fi
+
+ ${EPYTHON} setup.py build || die "src_compile failed with ${EPYTHON}"
+}
+
+python_test() {
+ cd tests/ || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ./build/doc/. )
+ distutils-r1_python_install_all
+}