summaryrefslogtreecommitdiff
path: root/dev-python/python-efl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-efl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest5
-rw-r--r--dev-python/python-efl/metadata.xml19
-rw-r--r--dev-python/python-efl/python-efl-1.18.0-r1.ebuild63
-rw-r--r--dev-python/python-efl/python-efl-1.20.0-r1.ebuild71
4 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
new file mode 100644
index 000000000000..4e7839f745b6
--- /dev/null
+++ b/dev-python/python-efl/Manifest
@@ -0,0 +1,5 @@
+DIST python-efl-1.18.0.tar.xz 8927932 BLAKE2B c1b41e1316c78fc42cf21541aba386dce799f1ec26549dda8c547de4cf47870a100070bb442d21116ce956808bcf948eba96601343512ba61fb1fc472e2574be SHA512 c1fc8d4129c2ac61b367ad373ad676a60cf0aed4c9150104d7e81bf464c44a3a5ae555d2298bbf1bdf6a3d6ba3b7d934af390e36755a1516972db2675d920c2b
+DIST python-efl-1.20.0.tar.xz 8984492 BLAKE2B 526c530d7b8dad59d01cefcbb6cad2710cb46c3b62eb0b2746c3552c8c1ef42cc4691072fbbce16a8a3b6ea9d6b5651a3645ca739e569a0f4db3dd9988ddf2fa SHA512 93d8d6c990350074e203bf3632d92b5253f34f318b30357b05ab5ab73a9f6656d127ff0c1831af1bf7c736822b483c12754085e52103eb0e41362cc28db5651f
+EBUILD python-efl-1.18.0-r1.ebuild 1481 BLAKE2B 529a6def5b6c9f1cdf49683c5307b90ea3281cbbad85a71dc69745fd6d853f9698d06805ae87a64d810170b5612a8fc04cfcb382dda21aa8df135d5379d39ec4 SHA512 3a2b5e0dd91ebaf1f8992134f8f80f6f67b02e19db98e0263c6b91249ef41df35f47c77e37afed37522649b98d30d25b58037d4ec9c923ee60c45679dc8bf7d7
+EBUILD python-efl-1.20.0-r1.ebuild 1767 BLAKE2B 2f770e0c9f80a024c94cc508c2b19a55e131392b232b5048d936a73cf2ff1c02f61635f5fd4a0472191b01088d871fc4a4452b3ead10c8cb0fdc89a0f92e81dc SHA512 d1ad00014745970625ca74450559f25db4ae025507527e2369669cea1d7363f10537e4fbaaac56fc8d6872acf7f5273d0652c480807f22e3494e2eac1cac90f6
+MISC metadata.xml 678 BLAKE2B f63779daf5a74d59f8dc65002ae8ec55585ae58c2bb02d951fd1ced15fd68fbb4ffa18239b8ef48347ff18e5cf033faa4a141f8e4fd8898bed6d74a9fd18d065 SHA512 a618f3bf8c4eed0e00b889f2c1bc85d46dc5ef1118f393f4cf10857d0b1a75720c6a719ed97117e40420600059e34eff0be3771fa684b89d437459f012fb7c5c
diff --git a/dev-python/python-efl/metadata.xml b/dev-python/python-efl/metadata.xml
new file mode 100644
index 000000000000..1b546bfae6dd
--- /dev/null
+++ b/dev-python/python-efl/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>juippis@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ EFL is a collection of libraries for handling many common tasks a
+ developer man have such as data structures, communication,
+ rendering, widgets and more.
+
+ PYTHON-EFL are the python bindings for the whole EFL stack (eo,
+ evas, ecore, edje, emotion, ethumb and elementary)
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-efl/python-efl-1.18.0-r1.ebuild b/dev-python/python-efl/python-efl-1.18.0-r1.ebuild
new file mode 100644
index 000000000000..7ea20dda1803
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.18.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ =dev-libs/efl-1.18*
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? ( =dev-libs/efl-1.18*[X] )
+"
+
+# Broken beyond repair. Fixed upstream for 1.20.
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc ; then
+ # Point sphinx to right location with built sources
+ sed -i 's|"../build/"+d|"'"${BUILD_DIR}"'/lib"|g' doc/conf.py || die
+
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${S}"/tests || die
+ # violates sandbox
+ rm -f ecore/test_09_file_download.py || die
+ sed -i 's:verbosity=1:verbosity=3:' 00_run_all_tests.py || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( build/doc/html/. )
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/python-efl/python-efl-1.20.0-r1.ebuild b/dev-python/python-efl/python-efl-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..629baf98e201
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.20.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ =dev-libs/efl-1.20*
+ >=dev-python/dbus-python-0.83[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+"
+
+python_compile_all() {
+ if use doc ; then
+ # Point sphinx to right location with built sources
+ sed -i 's|"../build/"+d|"'"${BUILD_DIR}"'/lib"|g' doc/conf.py || die
+
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${S}"/tests || die
+
+ # Tries to download a file under /tmp
+ rm -f ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm -f ecore/test_10_file_monitor.py || die
+
+ # Seems to need connman up and running during the test, requires:
+ # net-misc/connman
+ # dev-libs/efl[connman]
+ rm -f ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' ecore/test_08_exe.py || die
+
+ sed -i 's:verbosity=1:verbosity=3:' 00_run_all_tests.py || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( build/doc/html/. )
+ fi
+
+ distutils-r1_python_install_all
+}