summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/python-engineio
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest2
-rw-r--r--dev-python/python-engineio/python-engineio-4.3.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 91b0a5dd29f5..2e1eeebe94d4 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,3 +1,5 @@
DIST python-engineio-4.3.2.gh.tar.gz 299722 BLAKE2B 87dece98d72b7b0384e3b9d57062a3eaa7aeb80ac3f2f685d50b8816e122398ffd54da1f4b99a90a1f535e2d0f0d282167a682de022373e6108f7e91f8689aa1 SHA512 59933a0093167042a3873ba1561d2859359a5ad160f6b7b5c19478b1f73d1bd068779942c8bfc44dd5a8d9f155359571298b960bcd217aab341bdfec35bc5b28
+DIST python-engineio-4.3.3.gh.tar.gz 300494 BLAKE2B 302de4432717154258748602598d455650e858d3193127054abbd6d4e070255b26f38d08f620769b4782b29c43a9e6255896ff1192878c23b033168328036f90 SHA512 a8022b853c0a249e269c1e682f28d67022a2bd44975d67ea55e5244a02b540cded8042d7e9cbc5461f2a12970b64c00fa6d2e1a91ce93926fb0eace60096dccc
EBUILD python-engineio-4.3.2-r2.ebuild 1763 BLAKE2B 74e891a2966f99ed984f7fe7d7cd651c92ee1242a9b7679053f493a9632c210ead89460208cb716c15231175004e9f37caeb17a240730553476003f787f5b7d5 SHA512 754b43f5240620970c9694b0be0cc64b44e48b653ddabebcd66285356b08333b5ffe2501792808f74216cf1de2dbdb27cc83e270e8ddd1d4eaeebfc675027474
+EBUILD python-engineio-4.3.3.ebuild 1600 BLAKE2B 61bc9b1474a880cb8f2de42a45fe5b00d9f57fbf0780b9eb0a2ae4acd6043c8173e17803673cea5a91fa57be40b8e07783d8eb24247ef4bf8cd19d637497d237 SHA512 03e16152123590786bbf7f9bbb2c563a5499a6e07dcb176c29884e94baf3e3a5240e1b1157715b297d85974c894b1e0a6b50423566116c5685f11bcaf7df183a
MISC metadata.xml 518 BLAKE2B 7325d24cc26b1a3b4e2dec04159cdd4ebcceaf0384fccbee11205f9c000b1e9f84f97c742a6181dbad419e2527c6f874bc3f89760daa6b6dd2feb9b1f874b515 SHA512 40fe9ac96224019d28206f75ae6249c75dbcb759918c03826af4f8a394586bd5df445ef475cd009e8af93ea5c7424abebbbfd65ac2e2eb7bdd9e8a29f2dcb34f
diff --git a/dev-python/python-engineio/python-engineio-4.3.3.ebuild b/dev-python/python-engineio/python-engineio-4.3.3.ebuild
new file mode 100644
index 000000000000..3853dc3895da
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.3.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+# eventlet doesn't yet support Python 3.10, so let's work around it
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8,9} )
+
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ if ! has_version "dev-python/eventlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/common/test_async_eventlet.py
+ )
+
+ EPYTEST_DESELECT+=(
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+ )
+ fi
+
+ epytest
+}