summaryrefslogtreecommitdiff
path: root/dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 08:31:06 +0100
commitb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (patch)
tree6ff0b08fefeec2ae1d739e566814553b80b9d685 /dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild
parenta6266c63b23ed0ee16865627ca53e4f5353f0a5c (diff)
gentoo auto-resync : 17:07:2022 - 08:31:06
Diffstat (limited to 'dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild')
-rw-r--r--dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild b/dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..a1df11de9086
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.io/"
+SRC_URI="
+ https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_uinput.py
+)
+
+python_configure_all() {
+ esetup.py build_ecodes \
+ --evdev-headers \
+ "${ESYSROOT}/usr/include/linux/input.h:${ESYSROOT}/usr/include/linux/input-event-codes.h"
+}
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}