summaryrefslogtreecommitdiff
path: root/dev-python/python-fchksum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-fchksum
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-fchksum')
-rw-r--r--dev-python/python-fchksum/Manifest4
-rw-r--r--dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch26
-rw-r--r--dev-python/python-fchksum/metadata.xml8
-rw-r--r--dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild21
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-fchksum/Manifest b/dev-python/python-fchksum/Manifest
new file mode 100644
index 000000000000..d34a70181ad7
--- /dev/null
+++ b/dev-python/python-fchksum/Manifest
@@ -0,0 +1,4 @@
+AUX python-fchksum-1.7.1-md5-align.patch 699 BLAKE2B 6a1f30d90caa64cdf353a8c264da5794d3fa2098bcb4454073e3c76a87e7799dbede7f050b77048f711462dd6b4c915a7f107cd9e1e2d290b8a8c9f4101b564e SHA512 53b32029e211ee374c8b3a10680959af36a7a85b2b243bfc13fde6b195236fc2a6295e2d3b66be621773105f709467f48a711b2bc8de2342245a300aa55c557b
+DIST python-fchksum-1.7.1.tar.gz 26724 BLAKE2B 63385862b770c30098f80912c37b9e559fa4a1f400dcc30777cc8af4fe8abc2f658e41fc33035d7c6f04624960b499b04ae03257656589cd24986cd7f8273f5d SHA512 59b561e2938c41bcda2b98eb3fa0670be3fd85f8cb67368132ce239cac21760a5e9a5a05be2429992fa480ccd2e2aa457df7b4a07e709acbe42be9b1559f3060
+EBUILD python-fchksum-1.7.1-r1.ebuild 678 BLAKE2B 4181e0a13070974d472bf6119ddc7bdfb6010629a5cf16eb71d352a960d896a0be6a73d0f0a3ddbc6e9afbfdafa0d75cc69ee17360f4948e73c47917f69b0748 SHA512 3e0a99d09b9a61740ec63e9f9677b755f22772fb1ffeb610068dd483e9cffc095a78222279f75e386e4ddbe9b5391e9d431991625abe2a8b152477575591aa7d
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch b/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch
new file mode 100644
index 000000000000..1adfa627fdd8
--- /dev/null
+++ b/dev-python/python-fchksum/files/python-fchksum-1.7.1-md5-align.patch
@@ -0,0 +1,26 @@
+the alignment of resbuf is not guaranteed, so use memcpy to move
+the bytes in/out. on arches which can do unaligned accesses, this
+will generate the same code.
+
+patch by Mike Frysinger
+
+--- a/md5.c
++++ b/md5.c
+@@ -74,10 +74,13 @@ md5_read_ctx (ctx, resbuf)
+ const struct md5_ctx *ctx;
+ void *resbuf;
+ {
+- ((md5_uint32 *) resbuf)[0] = SWAP (ctx->A);
+- ((md5_uint32 *) resbuf)[1] = SWAP (ctx->B);
+- ((md5_uint32 *) resbuf)[2] = SWAP (ctx->C);
+- ((md5_uint32 *) resbuf)[3] = SWAP (ctx->D);
++ md5_uint32 swap;
++#define set(i, c) { swap = SWAP (ctx->c); memcpy (resbuf + (i * 4), &swap, 4); }
++ set (0, A);
++ set (1, B);
++ set (2, C);
++ set (3, D);
++#undef set
+
+ return resbuf;
+ }
diff --git a/dev-python/python-fchksum/metadata.xml b/dev-python/python-fchksum/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/python-fchksum/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild b/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..309636264d0e
--- /dev/null
+++ b/dev-python/python-fchksum/python-fchksum-1.7.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to find the checksum of files"
+HOMEPAGE="http://code.fluffytapeworm.com/projects"
+SRC_URI="http://code.fluffytapeworm.com/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-md5-align.patch )